Audio Recorder Works but Audio in Screen Recording Doesn't

May 24, 2021

Hi All, 

I am attempting to record my screen in Storyline with audio. The screen records fine, but no audio is recorded. When I open the screen recorder, the mic shows no activity as if it is not picking up any sound. The strange thing is, the audio recorder in Storyline works just fine and works on the rest of my computer system. It seems to just be the audio recorder within the screen record tool. 

I am on a Mac running Storyline within Parallels desktop. I've tried renaming the file so there are no special characters and am saving the file on my local C drive. 

Any help would be greatly appreciated! Thank you!

14 Replies
Lauren Connelly

Hello Dylan!

I'm happy to help! Is the audio missing even when adding the screen recording to a single slide? If you recorded audio with your screencast, it wouldn't be included with step-by-step slides. However, it'll still be available in the original screen recording if you want to insert it as a video on a single slide.

Also, if you are recording using a headset, have you tried unplugging the headset to see if the audio is recorded when switching the microphone?

Once I gather these details, I should be able to point you in the right direction!

Lauren Connelly

Hello Elena!

We are happy to help figure this snag out with you! It sounds like this has only been happening recently, and before you could hear audio from a recorded video. Have you tried recording audio in a new project? If so, does the audio work in a new project?

Also, are you using headphones or your computer audio? Have you tried switching the audio to see if that makes a difference?

Becca Levan

Hello Elena!

Thanks for sharing those extra details with us, and sorry you're still hitting this snag! 

When you go to record your screen, what default device are you seeing? Here's how to check:

  1.  From the Slides tab, click the Record Screen dropdown.
  2. Select Record Your Screen.
  3. Click the Settings icon. 

Do you see the correct default device selected for audio? Here's a screenshot of mine:

I'm staying tuned for your response so we can go from there!

Elena Shilo

Hello Becca Levan!

If I choose a Microphone, then the sound is recorded, but it is recorded from the Microphone

(that is, not only the sound of the video, but also the external sound in the room).

I need clean sound as it is in the video, without random background sounds (which appear when writing through the Microphone).


Maria Costa-Stienstra

Hi, Elena!

If you look at that same screenshot that my teammate Becca shared above, does the device listed under Speakers match what you are using (the headphones you mentioned above)? 

Since you are using Storyline with Parallels, I wonder if your headphones are not set to work on the Windows side, or changed after a recent Windows update. Can you try using your Macbook speakers instead so we can test this?

Let me know if this works! 

Luciana Piazza

Hi Ellen, 

Thanks for reaching out about your screen recording audio. I'd like to hear more about your setup!

  • Are you recording the screen recording on a PC or Windows on a virtual machine environment? 
  • As you record, does the No Audio option remain selected? I'm curious if it's toggling over to your desktop audio. 
  • Have you unchecked the Microphone and Speaker Options, as Becca recommended earlier, from the Settings Icon? 
  • Are you experiencing this if you try creating a screen recording in a new Storyline project?

Feel free to share your .story file with us in this thread or privately in a support case so we can examine your setup more closely.

Looking forward to hearing from you! 

Jose Tansengco

Hi Ellen, 

Would you mind unselecting "Speakers" under Audio Recording to see if this makes any difference? Also, if your videos are intended to exclude any audio, you can use the Edit Video feature to reduce the volume of the video to 0. Just slide the slider to the left to reduce the volume by 100%.

Let me know how it goes!

Eric Santos

Hello Ellen,

I'm happy to chime in. You are correct that the audio file is still there even if the audio level is set to 0%. I appreciate you sharing your recording setup, and I noticed that the Speakers option is selected. This explains why the recording picked up the podcast playing in the computer speakers.

Speakers option

Can you try recording with the Speakers box unticked? We'd be happy to help further if the issue persists. Looking forward to hearing from you.