Baked in Table Results in Publish Error

Jul 31, 2019

Has anyone else experienced publishing issues with tables**? Is this just a bug that Articulate does not have a solution for?

I was building a course this last week in which a table was used. Since the client did not have an already existing table for the content, I created one within the Storyline file so edits could be easily implemented. When it was time to publish the course, both my colleagues and I could not publish the course.

Eventually, after exhausting all other options, we started publishing the course with a different slide removed each time. Thankfully, the course was only 8 slides. By doing this, we discovered that the slide with the table* I created was the slide that was causing the publishing error.

As a solution, I made a separate file that only contained the table. Then, I exported the table out as a .png and used it to replace the editable table from the course I needed to publish. 

Thanks,

Ellie

* We also noticed on the problem slide that if the space-bar was used at all to pause the timeline while playing it, we received the same error message we were getting when we were unsuccessful with publishing.

** We tried publishing the course with the original table on several different accounts, one that was recently updated and on an account that did not have the most up to date articulate apps. We even tried publishing locally on our desktops, and trying to publish to different locations on our server. Nothing was working. We even tried creating a new Storyline file and imported the slides from the problem file.   

7 Replies
Ashley Terwilliger-Pollard

Hi Ellie,

Thanks for reaching out and sharing all those steps! It helped as I tried to recreate the behavior by adding a table into Storyline and publishing the course. 

I was able to successfully publish for Web with the table included, so it doesn't appear to be a bug with Storyline and tables.

You mentioned trying to publish locally and to different locations on the server. Are the files stored, edited locally? Working from a network/shared drive could cause corruption in the file, even in just a part of it such as a table.

Importing it is a good step to try and resolve corruption issues, but it doesn't always work. I'd look at opening a new .story project and add in a new table to see if that file works well for you. If not, please come back and let me know so we can dig a bit deeper! 

Alec Vincent Villamarin

I have also observed this just recently. I noticed that when the table starts/appears:

  • The timeline stops where the table starts
  • Audio continues
  • Any other animation does not show up - This means that if anything else is supposed to appear, including navigation buttons, they won't show up.

This was my workaround:

  • Use a text box or shape (where you can also put your text in)
  • Save your table as an image

I hope Articulate works on this bug. Tables are essential in presenting information.

Alec Vincent Villamarin

Hi Lauren,

Unfortunately, I can't share the exact file as it contains sensitivie information, but I'll try to replicate eventually so your team can work on a fix. According to some of my teammates, they have experienced such and it may be true for copy-pasted tables from PPTs. In my case, I can't fully recall if I did such, but I think I did not because I simplified multirow tables and columns to just one row - though again, I can't recall 100%.

I'll go back to this thread once I'm able to replicate it.

I love that your team checks on customer feedback. That's greatly appreciated.