blank/black slides on ipad

I've got a course where I've inserted screen recordings (mp4) onto the slides.  There are 12 slides total with videos of various lengths. The largest published video is just under 10mb.. The smallest is about 180k.

After the first slide plays fine, the rest go black.

From there using the next button or menu results in intermittent playing, but mostly black slides.

The Flash version works fine.  Just the ipad version is not working right.   I've tried in Safari and Dolphin on the ipad and same results.

Here's a link - http://pearson.siliconghost.com/cvo/nncw/notetaking/story.html

Articulate tempshare - http://tempshare.storyline.articulate.com/p16vr1o2grlth1iahfrt1skmu3j4/story.html

The first slide plays fine for me, but the next two go black and then it's hit or miss after that.

Anyone else experience this?

Update1 - I've noticed that videos that do play will display the quicktime logo for a second or two before the video starts.

Update2 - Not sure if this is a bug or related to the playback problem, but in this version 'video controls enabled' I'm able to control the video playback separate from the seek bar. For example, i can pause the slide at 50% through and then control the video playback independently with the video controls.

Or, should the video not start playing right away and the seek bar has already started then i pres the play button on the video controls.  Now, the seek bar is ahead of the video playhead and will jump to the next slide (set automatically) before the video is complete.

Update 3 - There definitely seems to be a syncing problem with video and the main playhead/timeline. I've tested in both safari and dolphin and the same syncing problem occurs. I wonder if this is the underlying problem ppl have been experiencing w/ video playback on the ipad.

14 Replies
Peter Anderson

Hi Chris,

Doesn't look we came to a definitive cause / solution for the above case. If you have a file of your own you'd like us to take a closer look at, please feel free to open a ticket and send us the .story file. 

Otherwise, have you checked the following tutorial that describes how to publish a Storyline course for HTML5 or iPad distribution which includes several frequently asked questions regarding mobile deployment? 


Here's the link to the article: 
http://community.articulate.com/tutorials/products/publishing-a-project-for-ipad-or-html5.aspx 

Also, have you tried viewing the content using the Articulate mobile player app? 

When viewing content on an iPad, you can use either the Articulate mobile player app (recommended) or the mobile Safari browser. To compare how Storyline content behaves in these environments, please review the following article: 
http://articulate.com/support/kb_article.php?product=st1&id=1fy8vvf3ukr9 

Chris Wall

I have not yet opened a ticket (we're still evaluating the product).

I have not yet viewed that video clip, but will as soon as I complete this reply.

I've uploaded:

  • Both HTML5 and Articulate Mobile Player app versions together in the same upload
  • HTML5 by itself
  • Articulate Mobile Player app by itself

I've also:

  • Changed the video resolution from 720 x 540 to 640 x 480
  • Tried setting and clearing the video controls enabled checkbox

Unfortunately, I'm still unable to view the video clip I loaded (I have a post in the thread that brought me here that includes a link to the course on your tempshare site). It's only three slides long as we were hoping to confirm that we could run video clips that were created in other applications such as Camtasia.

If we needed to, we could also build our sims using the Storyline tool, but we have a lot of existing video content in the form of videos/simulations that we've already published to MP4 files, and we're hoping to avoid that.

Thanks.

Now it's off to check out the links you sent.

CW

Chris Wall

I'm sorry to say that I'm still unable to view the content of the MP4 video in the mobile app. I went so far as to create an account on Articulate-Online and launched the course from there.

It's weird, because when I launch the course from Articulate Online, I can see the opening screen shot of the video clip, and I can see the video control bar down in the bottom, left-hand corner of the screen playing the video (it's a 6 minute, 1 second video clip, so I can see the time counting down on the left side of the video control bar and incrementing on the left side of it as the bar itself turns color from white to blue  as the white circle moves down the track).

Still, there's no moving video and no audio.

I'm convinced I must be doing something goofy, but I'm just not sure what.

I'll try your ticket suggestion.

Thanks.

CW

Leslie McKerchie

Hi Zio! I checked on the case that Chris submitted and our support staff was not able to re-create the issue and upon publish worked fine for the user as well. Here were the tips/suggestions that were sent to the user:

It is possible that the MP4 video is associated with QuickTime application. QuickTime does not only open or run MOV files but also other video formats, seehttp://support.apple.com/kb/HT3775

As for the format that Storyline converts the embedded videos, here's how Storyline encodes movies you insert into your courses, based on the file format of your videos and the publishing options you choose:

http://articulate.com/support/kb_article.php?product=st1&id=es3kzctg3aoq

On the other hand, the following tutorial describes how to publish a Storyline course for HTML5 or iPad distribution and includes several frequently asked questions regarding mobile deployment:

http://community.articulate.com/tutorials/products/publishing-a-project-for-ipad-or-html5.aspx

Evelyn Hamm

We are currently running into the same issue which Bill has posted.

We are working with screen recordings via Storyline. Some Slides are shown black. At most times it is only about a few seconds, at other times we have to reload the project.

It may has to do with fulfill Screenshots which are pasted on some slides?!

I will open a support case now.

If there is anyone who knew how to resolve that, it would be nice if you could post a solution in this thread.

Leslie McKerchie

Hi Evelyn!

Looks like Eloisa was not able to reproduce the issue and would like you to take a look at the output she published. 

I've seen other users mention issue with iOS10 and their LMS that they are looking into further. Sounds like this may be what you are experiencing as well if it cannot be reproduced in SCORM Cloud.