Button Hover States are getting stuck

Feb 03, 2023

Hi Community! I'm editing a project file that has a few menu slides throughout the course.  The buttons are built with the standard Normal, Hover, Selected, and Visited states.  When you return to the menu slide, each button is showing as Visited but is stuck in the Hover state. You have to move back over the button to have the Hover state disappear.  Any ideas on why this is happening?

16 Replies
Walt Hamilton

When you click on it, you are also hovering over it. So if your slide is set to saved state on revisit, the hover state is still showing. It will show until it feels a the cursor moving off. You can set the slide Tom restore to initial state, and that won’t happen. Of course, the visited state won’t show either.

One cure is to delete the hover state. Another is to reset the slide on revisit, then when the timeline starts, set all the buttons that have been clicked to visited. You’ll need to create variables (T/F works best) To keep- track of them.

Personally, I prefer not to use hover unless it is the only action. If the button has to be clicked to function, I don’t use hover. I always use variables, for the increased reliability and flexibility they give me.

Brad Glenn

Hi Walt,

Thanks for the quick reply! I've checked some of our other project files with a similar menu screen set up, and all buttons show only the visited state when you return. The only difference is that there are not Selected button states on this menu.  I tried deleting the Selected state of a button in the file with the stuck Hover state issue, but it was the same result - when you return it is showing the Hover and Visited state.

It does seem like this can be fixed without variables as the other project's buttons are remaining in only the visited state when you return to the menu screen.

Any ideas on why there is a difference between these two projects?

Any guidance is greatly appreciated!



Mischka Zeldenrust
Nick Eastham

This behaviour seems to have crept back in with version 3.83.31444.0

My buttons sometimes remain on Hover once I've moved the mouse away. Happens to any of my buttons, not just specific designs. 

v3.82.31354.0 seems fine.

I can confirm I'm dealing with the same issue since the 3.83.31444.0 update. Installing 3.82.31354.0 also fixes it for me.

Thank you for adding to this thread, it saved me from even more troubleshooting.

I added a screenshot to show what the problem with the Hover states looked like on my end when publishing with 3.83.31444.0.

Steven Benassi

Hi Raja and Sarah!

Sorry to hear you have also been affected by this issue!

I've included you both in the bug report being tracked and will update this discussion as soon as a fix is in place. In the meantime, as a workaround, we suggest downgrading to a previous version of Storyline 360 where this bug cannot be observed.

Thank you for your patience. I'm sorry if this has been slowing you down!

Jose Tansengco

Hi All!

I'm happy to share that we just released Storyline 360 (Build 3.84.31647.0) which includes the fix for the bug:

  • Hover state gets stuck when you quickly move your mouse over objects with hover states

Now all you need to do is update Storyline 360 in your Articulate 360 desktop app to take advantage of the newest bug fixes and features!

If you run into any issues, please don't hesitate to reach out to our team by submitting a support case.