Can't access Theme

I have been using a theme for several weeks now on a few different projects. Today I wanted to test an interaction, and decided to create a new project for this purpose. However, I was unable to access my theme. Even in existing projects, where the theme exists, if I try to select it from the Design or Master Slide tabs, I get the following error message:

I haven't moved or altered this file, so I'm perplexed as to why I can't access it (especially since existing projects make use of it).

Can anyone suggest a solution?

9 Replies
Christine Hendrickson

Hi a mac,

Hmm, strange. I personally haven't seen this happen before. It looks like there's an issue with the theme file itself. Do you have any other custom themes you can try to use and see if you receive the same error?

Also, I know you mentioned you haven't changed the location of any of the files, but I just want to make sure you're working locally. You probably are, from the sound of it, but never hurts to double-check.

  • Work on your local drive (your C: drive). Working on a network drive or a USB drive can cause erratic behavior, including file corruption, loss of audio, and other unexpected behavior. 
  • You should also make sure the directory path to your project files and your published output is less than 260 characters (for example C:\Articulate).
  • Avoid using special characters, accents or symbols in your file names.

Additional information regarding "Naming Files, Paths, and Namespaces" in Windows operating systems can be found in the following Microsoft article.

Adam Mac

@ Christine

I don't have any other custom themes presently. I may create and test some quickly to problem solve.

I save my files to a D drive, but all installation files exist on a C drive. While we do make use of network drives, I have not stored any content on them. (however our intent is to share files between publishers on a network drive, so your comments concern me to a degree - do you have more information regarding the use of network drives?)

Directory file name length / special characters aren't an issue. As a best practice I keep file folders short, as I've run into this problem with our SharePoint site in the past.

@ Peter

Will try the repair method, then test some new themes as per my note to Christine above. If I don't have a resolution, I"ll contact support.

Thanks for the replies,

mac

Christine Hendrickson

HI a mac,

As mentioned above it's really a good idea to try to avoid modifying files on a network drive. This isn't limited to Storyline files, so if you run into issues with files on a network drive (or any other external source) it would be a good idea to move the files to your C: drive and see if that resolves the problem. 

Let us know if you are able to see any differences in the theme if you launch it from the C: drive, or try another theme.

Thanks!

Adam Mac

Re-install didn't solve the issue.

Regarding drives, my C and D drives are both local. The template files are all saved in the default directory designated by StoryLine.

However, I was able to create another theme (identical), and use it without issue. So my guess is that somehow my theme file was corrupted.

Adam Mac

Well yes and no. I'm still testing to ty and figure out what's going on.

I have duplicated the problematic theme (Theme1), and created 2 new themese (Theme2, Theme 3). So far, with SL open, I can change themes without issue between projects (opening them within SL). The moment I close SL, and attempt to open a project and then change the theme ... I'm getting the same error message.

I even delete all previously existing themes from my drive.

If I can't get this resolved I'll contact support as mentioned above.

Adam Mac

Resolved:

  • Removed existing themes
  • re-created theme from scratch
  • removed project specific elements*

*What I think happened was that my main project file included Markers on one of my Slide Master Layers. These markers had triggers to other slides on my main project. As a result, when attempting to load this theme into the existing project, or others, I got this error.

By re-creating the theme, I decided to remove the markers from the Slide Master Layers, and I no longer get the error message.

Christine Hendrickson

Nice job!

Very happy to hear you were able to find out what was causing this. We probably would've missed that without access to the files, so I'm glad you were able to test it on your end and pinpoint it.

Again, nice job. If you run into any other trouble, just let us know.

Have a great day :)

Christine