Change state of button trigger issue

I'm having a problem getting one of my 'change state of' triggers to work.  It works when I preview the slide or the scene, but then stops working when I preview the entire project.

The trigger is set on the main menu of the course which contains a number of buttons which links to different scenes (different sections of the course).  It is set so the button that links to the assessment scene (section), which is set to disabled by default, is switched to normal when all the over buttons on the main menu are in the state of 'visited'.  This effectively unlocks the assessment once all sections have been viewed.

Again, this works absolutely fine when previewing the slide or scene, but fails to work when previewing the project. I have the slide set to 'resume saved state' when revisting.  Please let me know if I'm missing somethingsilly here as this is a pretty intergral part of the course.

Regards

Mark

12 Replies
Ashley Terwilliger

Hi Mark and welcome to Heroes! 

When you're previewing just the one slide, what triggers are allowing it to change the state if you haven't visited any of the other slides in the menu yet? Could there be another trigger interfering with the change state trigger? You may want to review this article on how triggers fire and in which order. Are you able to share the .story file here with us so that we could take a look at your triggers?

Mark Sullivan

The trigger that is making the change is 'change state of assessment button to normal when state of all of buttons x, y and z are visited'.

This is set on the master menu slide and relates to slide 2.1 in the story,

I have attached the .story for your reference.  I have stripped the module down as the original attachment was massive!

Thanks!

Marko Stojkovski

Hi Mark. I took a look at your project now, and there was a discussion about this, so I suggest you take a look on this topic http://community.articulate.com/forums/p/49975/268858.aspx#268858 where we discussed about possible not-knowing issues when you have a trigger "change state of button to visited when button1, button2 states are visited:.

I suggest the way I and the other guy explained to do this.

Also, I noticed this, a warning about states of groups. I took a look at the project quickly, but you dont have such option as states of groups.

Helene Caura

Hi there

I have a similar issue, but not with buttons or conditions, just many stated. I have roll-overs that change the state of several objects from hidden to normal or vice versa. It works fine when I preview the slide, but not the scene or the project.

I deleted all the slides to show you just the faulty one, and now the preview doesn't work well, BUT the published file works OK. I'm pulling my hair!

I have attached the full file (put anything on the first page, fast forward the video, then select the "pre-embarquement" menu, select "Qui fait quoi?", then click "Voir", and click "Comite de direction" at the top, and roll over each photo or hand icon. Some text are missing, one is missing the French accent... so weird.

I can't attached another file. If you delete all the other slide and keep the "Qui fait quoi" slide, it works fine.

Please enlighten me!

Ashley Terwilliger

Hi Helena,

Thanks for sharing your file here and reaching out. I took a look at the preview of the entire course and that one slide (and the layer where the information is shown). I didn't see any difference between the two? I know my French is non-existent at best, so I may not be spotting the missing accents - perhaps you could include a screenshot comparison of what you're seeing so that I could use that to compare? You mentioned the published file works ok - which is odd, but at least reassuring that it's working! Did you already confirm that you're working on project files as described here and using the latest update of Storyline 2, Update 7? 

When you're testing the published content are you viewing it locally or within the intended publish environment? You'll also want to ensure you're doing the latter as testing it locally could cause odd behavior with your published file. 

Helene Caura

Hi Ashley

Thank you for your quick reply and help.

I have attached a PPT with screenshots of what I see with the complete file and the single file. It's reassuring that it's working one one slide... but scary that it's not working in my final file!

I'm using the evaluation version of Storyline, downloaded last week. My file name is correct. I'm testing locally because I wanted to make sure it was OK before uploading to the client's LMS. Do you think it could be causing the issue (which would be very bad, but still an explanation)?

 

 

Ashley Terwilliger

Thanks Helene for the file. I think it may have something to do with the font you're using. I don't have that font installed on my system so it defaulted to the system fonts and I published it here. I didn't see any missing text as in your first image and I saw the ' over the e as well. Do you want to take a look at the one I published here to SCORM Cloud? 

Ashley Terwilliger

Ha! Luckily no one hears me all day or else I'd be in trouble. ;-) 

What's the font you're using? If you've got a copy of it or can tell me where I can download it for free I can check further and see if it's something we can get our QA team to look at? Is it only associated with the accented letters? 

Helene Caura

;-) 

The font was elearningArt Hand woman (by default was in my Storyline file, I think I downloaded it from elearningart.com (I have an account). Here is the font attached for you to test.

The problem was only on one accented letter in one instance, and the other letters, accented or not, were not appearing at all. I know.

Thank you.

Ashley Terwilliger

Thanks Helene for sharing the font file. It seems exclusive to that font, and oddly enough as you saw when on that one slide when it's in the whole course with the hover state of those items?  When I tried to use this font in a new Storyline file, I wasn't able to get the accented characters to display in the font - I also tried using the "insert symbol" method vs. just assigning the font to the letters. You may want to look at using another font and there are a few "handwriting" style fonts here that you may want to look into using.