Character States Problem

Hi Folks -

 I am having trouble with two characters.  I want the characters to change states when I click on a button.  Here is what I have done.

1. Added the initial state character image to the slide (inistal state is Normal)

2. Selected the character image

3. "Edited States" to add the second pose of the characters image and called it Selected

4. Created Trigger to change the state of Character to Selected when the user hovers the mouse over the button and I unchecked "Restore on mouse leave"

When I preview the slide, the problem occurs.  I hover over the button and not only does the Selected state show up but the Normal state stays in place as well.  I want the Normal state to disappear.

5 Replies
Ashley Terwilliger

Hi Jami and welcome to Heroes! 

I wanted to point you to this thread about changing the state of a character, and some troubleshooting steps, but if you'd like to share your .story file here I'm happy to take a look to see what else may be happening. If you'd prefer to not share in the forusm, you're also welcome to send it to our Support team. 

Rebecca Fleisch Cordeiro

Hi Jami,

Sorry for the delayed response. Having a hard time keeping up with everything and emails are getting buried.

If you want the state to change during a hover and then restore, these instructions should work. I've done this for "Dave"... I'll let you do Atsumi.

First, I deleted Dave completely...just to be sure to eliminate any issues. Then

  1. Insert Dave in the desired pose
  2. Click to Edit States
  3. Click the duplicate state button
  4. Choose hover from the drop-down list
  5. Up in the toolbar area at the top left of the screen, click the pose button
  6. Choose your desired pose and insert it.
  7. Click the Done Editing States button

Please shout out with any questions