Closed caption text disappears when pause button is clicked

Thank you for implementing closed captioning! This is a great addition to Storyline, and we use it in every new WBT we build.

We are having a couple weird bugs, and wonder if anyone else is seeing this?

Sometimes, randomly, after clicking the pause button while the CC text is displayed, it disappears. If someone clicks pause so they have more time to read the text, this is disconcerting. I don't see anything different in the Closed Captions Editor window that I can adjust to fix the problem.

Another weird thing, I have a slide that has six short pieces of audio, it is a scenario conversation. If the CC text is turned on when the slide plays, and then replay is clicked, all six segments of the CC text is show simultaneously in a column covering the whole slide. Do you have any ideas about how I can fix this? I have tried adjusting the timing a bit, but nothing seems to work.

Thanks for your help!

Karen

22 Replies
karen forkish

Thanks Bob, for asking.

This is for a work project, and not something I can share. I was hoping that maybe I'm not the only one to have run into some strange behavior with the CC text.

I created a mockup screenshot (which I'm attaching) of what it looks like to replay the slide and see all of the cc text displayed at once. 

Ashley Terwilliger

Hi Karen,

I haven't heard of either of these issues, but I'd want to know a bit more about your set up before testing. 

  • What version and update of Storyline are you using? 
  • Do you see this while previewing, in the published output, both? 
  • If you've published it, what browser(s) are you testing it in? 
  • You're using the Pause and Rewind/Replay buttons from the built in seekbar, or ones you've custom created?

Also, if you can share a striped down version of your course, that would help with ensuring I'm using all the same settings as you. 

karen forkish

Hi Ashley,

Thanks for following up! Great questions.

I'm using Storyline v3.12.14594.

The captions that disappear when the pause button is pressed, is something we've only seen published to the Articulate server, in both Chrome (Version 64.0.3282.140 (Official Build) (64-bit)) and IE 11 (11.0.49). It may happen in preview mode, but we haven't seen it there.

Seeing multiple captions displayed on replay happens in the preview mode as well when viewing with a browser. I've only seen this happen when I have multiple character voices, and more than one audio file on a timeline. This happens often if captions are turned on, and then replay is clicked.

This all happens using the built in seekbar.

Thank you!

Karen

Alyssa Gomez

Hey Karen,

Thanks for that context. Would you be willing to share a sample slide with our team? That way we can test it in a few different environments and get a better idea of exactly what is happening in your file. 

If you would rather keep it private, you can send it along through this form. Thank you!

Pete Lewis

I'm experiencing a very similar issue here, version 3.19.1600.0, modern player.

When I play a slide with CC on and the timeline ends, the CC disappears when I jump back using the seekbar. I cannot get it back by toggling CC off and on again while either playing or pausing. The only way to view CC again is to replay the timeline (which means I have to seek forward to the part of the timeline I tried to get to to begin with). 

This has happened in all of the projects I've tested in Review and on my LMS (let me know if you'd like me to send a link to the project or a screencast of the issue). 

Thank you!

Pete Lewis

That's close, but if you seek closer to the end of the timeline (such that the timeline truly does end) and then seek back and press play, there are no captions, even if there is a new caption queue point in the SRT/VTT file during playback. 

I've reproduced it twice in this Peek recording...at 0:17-0:33 and at 0:40 - 1:13 in both cases, I've tried to let the slide audio run for a decent amount to demonstrate that no CCs are displaying, even new captions.
At 0:33, I clicked on the very start of the timeline - this hasn't generally played automatically, nor has it started the CCs again.
At 1:13, I clicked the restart button which has been the only way to guarantee the CCs returning. 

I hope this helps! 

Ashley Terwilliger

Thanks, Pete. I was able to view that video! I saw what you were describing and was able to replicate it, where the closed captions won't display when using the seekbar to navigate back to earlier points once the slide timeline has ended.

That's something I reported to my team, so I'll keep you posted here about any updates! 

Katie (Gokhshteyn) Riggio

Hi, folks. I'm excited to let you all know that Update 22 for Storyline 360 is live! 

We fixed the issues where: Closed captions disappeared when a slide was paused, and Closed captions didn't display when using the seekbar after the timeline has finished.

Check out all the new features and fixes here, and here's how to update Storyline 360 to enjoy everything this release has to offer. Be sure to let us know what you think!

Crystal Horn

Hey everybody. We released update 6 for Storyline 3! It includes enhanced features and fixes - Check them out here.

We fixed the above issues in Storyline 3 as well: Closed captions disappeared when a slide was paused, and Closed captions didn't display when using the seekbar after the timeline has finished.

Click here to download the latest version of Storyline 3. Let me know if you need more help!

cristina eleuteri

as I wrote even with private emails, my problem has not been solved. If I pause the video (by my custom pause button) I can stop the caption on the screen but not the timeline.
This did not happen with the version of almost a year ago and I don't understand why this function cannot be restored.

I would like to use new update but I need old functions....

Are there no news about this?

Thank you

Leslie McKerchie

Hi Cristina,

I was able to find where you worked with Crystal on this, and we were able to identify an issue with the closed captions not remaining when the base layer was paused.

I do not have an update at this time but will add this conversation to the report as well so that we can update you here and anyone following along.