Completion status not updating when quiz is passed?

Hello,

I'm new to Articulate, having previously used Lectora. I'm having an issue with a course passing the completion status to the LMS after the user completes and passes a quiz.

I tested the course out in ScormCloud, but the result is the same. It shows me the percentage score of the quiz, but remains incomplete.

My assumption was that the user would get completion credit for the course once they passed the quiz; In Lectora, I had to insert a variable / action on the "pass slide" in order to register a completion, but I don't know of any variable that I need to set in the course in Articulate. 

I'm publishing in SCORM 1.2, and setting the LMS reporting as Completed/Incomplete, using Cornerstone LMS

Tracking is set to use Quiz Result

10 Replies
Alyssa Gomez

Sorry to hear you're getting stuck, Mike! I'm happy to help. And thanks for letting me know you already tested in SCORM Cloud--that's usually the first thing I'll recommend. 🙂

I've got a few questions that will help me narrow this down:

  • What version of Storyline are you using?
  • Does the Result Slide have a "submit result" trigger?
  • Is there a reason you're using Completed/Incomplete vs. Passed/Incomplete?

If you don't mind sharing your file with me, I'd be curious to test it. You can either attach it in a new thread comment, or send it to me privately by clicking here. 

Mike Merkle

Hi Alyssa, 

Using Storyline 360.

Though I think that's what I was missing, the submit results trigger!  

Incidentally, I did test a version with the Passed/Incomplete setting to see if that worked better, but the content rendered very funkily when I launched the course (fonts not correct, strange characters appearing on screen...).Not sure what that's about.

Passing is assumed with completion of most courses since users don't get credit otherwise. 

Thanks very much!

Alyssa Gomez

Hi Mike,

Ah, glad we found the culprit! The Submit Results trigger sends the quiz data to the LMS, so you'll definitely want to make sure that trigger is on the results slide. 

You mentioned changing the reporting status to Passed/Incomplete caused the slide to look wonky (technical term 😉). That could happen if you tested the output locally. Did you upload the output to your LMS before you tested it, or did you test it locally?

Finally, the object field for that trigger indicates that the quiz data will be submitted when the slide timeline starts. 

Let me know if you have any other questions!

Mike Merkle

Added the trigger and re-tested, it did work this time.

I actually ran a version with the pass/complete setting in SCORM Cloud, so more curiouser (another technical term).  

It was a bit confusing because the object field seemed redundant with the results field, since both fields show the same "target"?

I actually have two submit results triggers, one on each of the respective results layers (success / failure), rather than on the results slide base layer.  This way the Object is "Success" or "Failure" for the respective trigger...a little less confusing.

Would it work the same way (or is it more proper) to have the trigger on the base layer and the results slide selected as both the Results and Object field, so the triggers on respective result layers not necessary? 

Thanks again!

Jessica Brown

I'm experiencing this same issue: I get a quiz result, but the course is not marked as complete when I test it in SCORM Cloud. (I've attached the sample course I threw together to test the function in our LMS). I'm publishing in SCORM 1.2; tracking is set to "results slide," LMS reporting is set to "passed/failed," and I do have a "submit results" trigger on the base layer. It seems I'm missing something obvious, but for the life of me I can't figure out how to make it complete once the quiz results are shown.