Correct Button States

I have a project that I am working on and can't figure out a particular function using button states.

Here it is:  I have a home page with button navigation.  I have all but one button set to disabled when they come into the project.  My project is set up into scenes (typical)  I added a variable so the home page buttons will go to a normal state after they go through each section of the course.  It works great.

Problem:  When the user goes back to the home page and clicks the newly activated button to go to the next scene, the button doesn't change to the visited state when they click on it and go to the next scene.  Any idea why the state won't change to visited once I have activated it?  I tried setting another trigger sending it to the visited state but that didn't work either.  Any ideas?

11 Replies
Christine Hendrickson

Hi Tracy!

Thanks very much for the file. First, I have to say I was very impressed. You did a great job with this. 

I took a look and I have to admit I made quite a few changes to get this to work. First, I removed all of the variables.. I'm sorry, variables make my eyes cross What I did was add triggers. The triggers I added fire when the buttons change to the "visited" state. So, when the users click on the first button, that button will change to visited. I set the next button down to change to "normal" when that first button is set to "visited". I did this down the line (very easily by just copying and pasting the trigger on to the next button/object) for each button.

I published the modified version here, if you'd like to test it. I'm also attaching the modified version, just in case you want to take a look at how I set up the triggers.

I know I made a lot of changes, but hopefully this will work for you!

Christine Hendrickson

Hi Tracy,

I'm sorry, I wasn't aware you would be using this on the iPad. That's a shame, it works so well outside of mobile. 

Update:

Actually, I just took a look on my iPad 2 and it's working quite well for me through the Articulate Mobile Player app. Strange. Are you using the link above? 

Here's a shorter link, just in case: http://bit.ly/YBQrcm

Can you take a look and see if it works for you now? If not, can you tell me what version of the iPad you're using, or how it's launching for you (through the app or Safari, etc.), please?

Thanks!

Christine Hendrickson

You'd have to upload the file that I attached to the LMS. But first, I would try just accessing it with the link I provided. I have it uploaded to Articulate Online. If it works for you there, on your iPad, but doesn't after uploading the new file to the LMS, it may have something to do with how they handle the content. 

Let me know how it goes

Tracy Scott

Yes, it did work when I lauched it from the link.  I took the file and published for LMS last night, uploaded to the LMS, and it didn't work.

I still need to learn how to go from the LMS to the Articulate player or do we have to publish to Articulate online to get it to work?  Question would be how do I get it to my Sales team...

Thanks for all your help.

Christine Hendrickson

Awesome, ok - that's good to know At least I know it'll work from there for you, that's a good start. 

When you're uploading it to the LMS, are you overwriting the original file? Maybe that's the problem, if so. You might want to rename the file and upload it as a fresh course. Then, when you're on the iPad, you'll need to visit the link for the course - this should automatically launch the app. I'm not sure how it would work on your LMS, but you should just need to navigate to the story.html file. Once you launch it, it will add it to the library. 

Note:  If your LMS requires that you identify a single launch file once you've uploaded your content, the file to point to is index_lms.html.

I don't think you'll have to use Articulate Online, this is just where I upload all of my content for testing. If you do want to try it out, though, you may want to try the free trial

Let me know if you make any progress. This is really a fantastic course, hopefully we'll be able to get it all set up for you.

Tracy Scott

Thanks Christine, I did load the new file as a new course so I didn't have the old version issue.  I am testing it in my sandbox so I wonder if that has anything to do with it.  I will try our production site and see what happens.  If it still doesn't work, it sounds like I need to go to the LMS vendor for help. Would it be an HTML5 limitation?

Thanks again!