Correctly-answered questions showing in review of quiz when 'Review only incorrect questions' is ticked

I've got a quiz with the attached trigger wizard, enabling the assessor to enter a code which enables them to enter review mode. As you can see, I've ticked the 'Review only incorrect questions', and it does indeed navigate to the first incorrectly-answered question when the code is entered and submitted. However, if there is more than one incorrectly-answered question, when I click 'next' it requires me to scroll through the correctly-answered questions that were answered as part of the randomised draw. So, if I answered the third and sixth drawn questions incorrectly, it will take me to the third question, but then I'm required to scroll through the fourth and fifth questions before getting to the next incorrectly-answered question, the sixth.

The question bank from which the questions are drawn has all questions set to 'Automatically decide' in terms of return state (I've seen on other threads it can cause problems otherwise). Any idea what's going on, anyone?

2 Replies
Leslie McKerchie

Hi Andrew,

Thanks for reaching out and sharing what you are experiencing with your project file.

We do have this recorded as a bug specific to question banks displaying correct questions during the review as well.

This is not something we've been able to replicate. With your permission, I'd like you to share your project file with our support engineers as we continue to investigate what's happening. You can share it privately by uploading it here. It will be deleted when troubleshooting is complete.