Drag n Drop decoys previously working fine, but no longer. Maybe linked to a recent SL 360 release?

Greetings!

A drag-n-drop interaction to select a correct ingredient out of a choice of six was working as it should up until some months ago. The course has essentially been in wait mode since then as translations and a sister course are completed. Now, however, one aspect of the drag-n-drop has been discovered to no longer be working as it was, without having changed anything. 

The learner can drag as many ingredients of the six as they like to the drop target, and then submit. Only one of these ingredients is however correct, but it is a common misconception that there are more than the one ingredient (thus the exercise.) So five of the ingredients are decoys, with 'none' selected as drop targets.  

The desired behaviour, previously achieved, is for the 'Try Again' feedback to launch for any incorrect drops, even if the correct ingredient is among other incorrect ingredients (in which case we trigger a 'partially correct' message as a hint.) Learners get five tries.

Now however, having not changed anything in the course page, dropping multiple ingredients where the correct ingredient is included does not launch the 'Try Again' feedback layer. Pressing Submit gets no reaction. 

If single or multiple incorrect ingredients are dropped without the correct ingredient, then the functionality works (i.e., Try Again.) If the single correct ingredient is dropped, the Correct layer is evoked as it should. 

I can even see an earlier test version published on Articulate 360 showing the desired behaviour. But when I now load that source file from these earlier versions into the latest SL 360 software, the problem described above occurs. 

Which could suggest that something fixed or enhanced in a recent release has had an inadvertent knock on effect. Maybe?

Very keen to get this resolved, as launch is now approaching.  Thanks!

28 Replies
Crystal Horn

Hi there, Daniel.  Thanks for reaching out.  I'm happy to see if I can determine what's happening, and to see if I can reproduce it in a new file.

Can you share your drag and drop slide here?  You could either share the entire .story file, or import that slide into a new file and just share that one.  I'd like to have a look at your setup so I can recreate and investigate if there's a possible bug.

Thanks!

Leslie McKerchie

Hi Wendy,

We do have an open issue for SL360 specifically related to what I see in your file:

  • Drag and Drop questions whose Drop Target have dashed outline and no fill are sometimes not evaluated correctly in the HTML5 output.

I changed the outline to a solid line on your drop target and it seems to be working.

Take a look at your attached file.

I will add this thread to our report.

Leslie McKerchie

Well Daniel, I think you may have uncovered an issue. I'm reporting this to the team. I thought it may have been due to your custom set-up, but I created a super basic Drag and Drop and experiencing the same issue.

I wanted to share some information on how we define bugs and how we tackle them when they occur.

In the meantime, would a Pick Many work for you? I did a rough example using your same slide information and attached, it's slide 1.2.

Update - Further testing confirms this issue only exists in the HTML5 output (which is also the Preview format) and the Flash works as expected.

Daniel Mensch

Hi Leslie, and thanks. 

Actually a big sigh of relief, since we are publishing Flash with HTML fallback. I've now checked test versions on the LMS and the DnD does in fact behave as intended there. 

My reactions were in fact based on the interaction's behaviour in Preview mode (thanks for that insight btw) and Articulate 360. We also publish with the Flash with HTML fallback setting to Articulate 360, but there the bug seems to be in action. Expected?

Great to get this off my worry list!  

Cheers, Daniel

Ashley Terwilliger

Thanks Wendy for that Peek - I made a note and shared that with our team. With the full rewrite we did to our HTML5 output and publishing engine it's a different set up than Storyline 2, that created a better set up and experience for most things. I'm sorry this one snuck through the cracks, but we're looking into how to fix it! 

Caryn Carman

Thanks everyone for this thread. I'm experiencing the same issues with a file I recently updated from SL2 to 360. I do use a dashed outline on the target, so I'm going to change that to see if it matters - hoping it's as simple as that. What may be a little different is that the slides on which I use these interactions won't even load in preview in 360. We'll see!

Caryn Carman

So I have two slides that use drag and drop functionality as mentioned above. I've change one target from a dashed outline to a solid outline. That hasn't made a difference so far. Meanwhile, the main issue is that neither slide loads in "Preview" so I can't really tell what additional problems there may be. I'm uploading here those two slides in isolation in hopes someone may have ideas. Thanks in advance!

Caryn Carman

Quick update - the issue seems to be tied to using groups, images, or text that is separate but laid over an image as the object that is dragged. When I deleted these items from the slide, the preview works. 

So the question now is, what types of objects and contexts can be used as drag-able objects in 360? Can someone share? I didn't find anything on this limitation when I searched earlier. 

TIA!!

Caryn Carman

I take it back. I rebuilt 2 separate slides. On the first, 2 of the 3 rebuilt triggers worked. The third did not. On the 2nd slide, after rebuilding it the same way I did the first, none of the 3 triggers worked. Then, when I went back and tweaked a rebuilt group on the 1st slide, the slide won't load again in preview (relevant to Spinning Cursor Effect above). Back to the drawing board.

Caryn Carman

Hi Alyssa,

Thanks for reaching out! I've managed to fix all but one instance of this. I'm attaching here the updated slides affected by the one remaining bug. For me, the 2nd work example (landscapes) isn't working. The slide hangs after it is dropped on the target. I can't for the life of me figure out what's different about this instance that's breaking it. I've tried deleting the assets and pulling them back in, I've tried un-grouping and rebuilding the group (and trigger), I've tried building the group in a different order, etc. 

I'm presenting the program from which this is pulled on Weds so really want to have it working. Thanks for any insights you can provide!

Crystal Horn

Hi there, Caryn.  Well, we've got some inconsistency even on our side.  While Alyssa doesn't see the endless loading in Preview and published output, I do.  So at least you aren't alone!

I'm going to share this with our wider support team to see if we can nail down what is the variant that is causing the loading.  Alyssa and I have the same setup on the surface, so I'm hoping the experts can look deeper and give us some next steps.

I'm opening a case for you, and I'll follow along.  You've done some amazing troubleshooting, by the way, and we're just as determined to get to the bottom of it!