"Drag up for fullscreen" control problem on IOS mobile

Has anyone seen this?  See attached screenshot (from Safari on IOS)

This control appears when the top of the screen is tapped.  It causes the browser  menu and top window chrome to display.  The control can be dragged up to 'push' the top browser chrome vertically off screen and allow the course content to go fullscreen. Problem is that once it appears, it never leaves, so it blocks some of the course content. 

Just wondering if anyone has any advice or experience with it and any advice on  how to get rid of it?

It also appears when using firefox on IOS so its not just a safari thing, but in firefox its very buggy and doesn't function at all...just blocks the screen.

So, is it a storyline HTML5 player function?  A buggy browser function?  or something else?

Appreciate any advice

Regards

 

 

 

 

40 Replies
Crystal Horn

Hi there, Peter.  I ran a quick test on my iPhone SE with iOS 11.2.6.  Check out my Peek screencast.  The prompt to "Drag up for full screen" went away after I dragged up.

It sounds like it persists for you even after dragging up.  Is that accurate?  Can you let me know what iOS version you're running on your iPhone?  You can find that in the Settings.

Also, for iOS devices, supported browsers include Safari and Google Chrome.  Firefox is supported for desktop viewing only.

Peter Moore

Hi Crystal..thanks for replying. .I wish the experience that you are having and show in the movie was the same for me :-)

‘I should add, that when  I click the hand icon, the text label disappears. So that piece of functionality does work.  But dragging the hand icon up...well, it never leaves the screen.  Is there a way to get into the file where the player is controlled in the published output folder, and switch the display of the control off while still retaining the ability to place a finger on screen and scroll the content up to fill the window...seems to me that the icon is somewhat unecessary given the expectation with mobile that you can generally scroll and push content around on these devices anyway .

i’m on An iPhone 7 with iOS 11.2.6

i also see that your course sample uses the storyline player controls, mine doesn’t.  I have them all switched off for a seemless and borderless experience. All navigation is custom.   Wondering if this is a cause of the problem?  I.e. does this control rely on there being some player area to work within?  I’m also testing this as a published scorm 1.2 course, although that shouldn’t make a difference here.....but you never know what effect things can have?

Was also good to discover that this is a storyline player function?.  I hadn’t tested for mobile like this before so was surprised when this control popped up...initially thought it was a browser function.

Appreciate any assist...I might make a screen movie later so you can see it happening if that would help?

Regards

UPDATE:  Crystal - Here's that screen recording of what I'm seeing.

 

 

 

 

Leslie McKerchie

Thanks Peter for that screen recording, that's certainly helpful.

Would you be able to share your .story file so that we can take a look as well? Sounds like you have some custom settings and it'd be nice to do some comparing.

If you cannot share here in the forums, you are welcome to share here privately.

Peter Moore

Hello Anna. I received some feedback from the support case I raised for this problem.  Looks like it might be a bug in the player. They are investigating further. My course design was borderless and it used a custom navigation. Meaning.  I had the built in player navigation switched off.  The support person from Articulate tried enabling the player navigation and reported back that after doing this, the drag up control started working normally. So if your course design was like mine...this might be a workaround worth considering.  Its not a solution for me because I don’t like those player nav buttons.  They’re not too intrusive on a mobile but I’m no fan of them on the desktop player.  Just my personal preference there.  Hope there’s something in this you can experiment with ?  

 

Matthew Bibby
Peter Moore

Thanks Leslie. It would be really helpful if someone in the tech team could advise if there is a “switch” in one of the output files in the published package that could be set to turn this control’s visibility off but still allow the content screen to be swiped or pushed up. 

Hi Peter,

As you probably know, Articulate don't support making changes to the published output. But given the nature of this bug, I can appreciate why you'd want a quick fix.

I haven't tested this, but try making this change:

  • Open story_htlml5.html in a code editor
  • Delete lines 63 through to 104 (see image below)
  • Save and test.

Don't be surprised if the line numbers you see don't match exactly. This code is right near the end of the file.

Here is the code you want to delete:

After you've done so, it should look something like this:

I hope this works. As I mentioned, I'm just guessing here, so let me know if this does the trick.

If you need to roll back these changes, simply publish your module again. 

Peter Moore

Thank you for this tip Matthew. That was really helpful.  I'm doing some testing on scorm cloud with those lines of code deleted from the story_htlml5.html file.  It initially seemed to work and I definitely spotted the course running with that hand slide control gone - several times too.   But before I could pop the champagne corks...the hand re-appeared... I'm trying to find out if its some tricky caching behaviour on scorm cloud, safari or with the way course updates/overwrites are handled on the scorm cloud site.  So I'm doing lots of deleting and resetting caches and files and deleting again. I'll post here if I get a breakthrough...but do appreciate very much you pointing this part of the html5 file out...its a great lead.  Regards

 

 

 

 

Mya Maury

Hello - I'm having the exact same problem as Peter. I'm using Storyline 360 in Safari 11 on an iphone 7 plus.  The hand only goes away when I enable the Storyline player, however our module is built with custom navigation (however I have the swipe right/left feature enabled).

Does anyone know if this bug has been resolved or if there's a work around to fix it?

Gwenaelle M.

Hi Ashley,

I had not seen your answer on this other post before posting here. I did not try anything about editing the text cause I could not find where to do so.

I'm now having the issue with it not disappearing.

I don't know if it may help but one of the modifications I made before uploading my new version was to edit the text of an other element : the one that is displayed when somebody does not answer to a question before clicking on the submit button. That's the only new type of modifications I made between the last two versions.