Drap and Drop not working

Mar 21, 2022

I have created a free form drag-and-drop quiz. I need the submit button to appear after all items have been dragged to a target, either a correct or incorrect target. 

Sometimes it works, other times I have to 'snap' the choice into the drop target. Drag 2 and drag 4 are not triggering the change of state on target 4?

I have attached a screen share of what happens when I try to run it and also the storyline file. 

4 Replies
Richard Watson


I previewed the .story file I uploaded and it appears to show the submit button each time I tried it.  Hopefully, someone else can jump in and see if they can recreate the problem you are experiencing. :)  I tried it via publishing on Google Chrome and Edge and also by previewing it and testing it from within Storyline 360.

Interested to see if someone can solve this "puzzle" for us.


Maria Costa-Stienstra

Hi, Starla.

Thank you for sharing your .story file!

I was able to reproduce what you're experiencing on my end. The problem seems related to the "dragged over" trigger, if the user drags a rectangle over another one already in that state.

I went ahead and opened a support case on your behalf so we can investigate this further. You should hear from our team soon via e-mail.