ERROR: Could not load the file 'story_content/data.swf' in mozilla

Dear All,

I have publish my elearning course to LMS package and upload it to our LMS. I tested with IE 8 and it works fine. Then, I tested with Mozilla and it failed to load the content.

The error message : ERROR: Could not load the file 'story_content/data.swf'. I also did test locally by using mozilla, the same problem error.

My mozilla Firefox version is  : 14.0.1

I tested it with Safari, and it works fine as well. I surprise how come it can't work in Mozilla, as all the way Mozilla never give me problem.

Anyone know how to solve the problem?

Regards,

Yulstar

23 Replies
Alicia Louden

Well, my Support ticket has gotten me nowhere so far. The response from Articulate Support showed a Screencast with my test course working fine in Firefox on their machines. They suggested I uninstall and re-install my browser. That just isn't a good answer for me. A large portion of my company uses Firefox for browsing. This thread shows that it isn't an incident isolated to my machine. Without further investigation and understanding into exactly why it isn't rendering properly in Firefox, how can I have any faith in using this tool to push out my materials? My company locks down our machines so we have to call IT to uninstall/re-install applications. I can't tell all my employees to re-install the browser if they have a problem. I need a better answer as to exactly why this is happening. I am completely frustrated. 

Lawrence Jacobson

I am also experiencing this problem intermittently and this is with an IE browser. What I did once which worked, but it does not always work, was to copy the data.swf file from another Articulate project that worked. This works some times but not always and when it doesn't work it seems to mess with the look and feel of the course.

Alicia Louden

Thanks, Peter! I updated and re-published, but it still didn't solve the problem for me.

After realizing my old Presenter courses would no longer play in Firefox either, I became suspicious that the issue wasn't with Storyline specifically and investigated further. It turns out there is a known issue with Flash player and Firefox if you have RealPlayer installed. I changed my RealPlayer preferences according to the instructions provided here: http://helpx.adobe.com/flash-player/kb/flash-player-113-crash-mozilla.html and now the courses play in Firefox.

I hope this helps others who are having the same issue!

Best,

Alicia

Marsha Jolliff

I am using RoboHelp 8. I created a demo and inserted it into the HTML page: Insert -- Multimedia/Demo. I inserted the story.swf file and I got the Normal 0 false false false oNotPromoteQF /> EN-US X-NONE X-NONE MicrosoftInternetExplorer4 /* Style Definitions */ table.MsoNormalTable {mso-style-name:"Table Normal"; mso-tstyle-rowband-size:0; mso-tstyle-colband-size:0; mso-style-noshow:yes; mso-style-priority:99; mso-style-qformat:yes; mso-style-parent:""; mso-padding-alt:0in 5.4pt 0in 5.4pt; mso-para-margin-top:0in; mso-para-margin-right:0in; mso-para-margin-bottom:10.0pt; mso-para-margin-left:0in; line-height:115%; mso-pagination:widow-orphan; font-size:11.0pt; font-family:"Calibri","sans-serif"; mso-ascii-font-family:Calibri; mso-ascii-theme-font:minor-latin; mso-fareast-font-family:"Times New Roman"; mso-fareast-theme-font:minor-fareast; mso-hansi-font-family:Calibri; mso-hansi-theme-font:minor-latin; mso-bidi-font-family:"Times New Roman"; mso-bidi-theme-font:minor-bidi;}Couldnot load the file 'story_content/data.swf' error. Maybe I'm inserting the wrong SWF file?

I have no problems in RoboHelp when I go to Insert -- Adobe Captivate Demo - xxx.swf

Peter Anderson

Hi Marsha

So it sounds like you're hoping to embed the Storyline course into a web page, is that right? Can you try publishing your course for web, and giving this technique a shot? Or do you mind giving more a little more information about the steps you're taking to get the error message you're seeing so we can go from there? Thanks!

Marsha Jolliff

Normal 0 false false false oNotPromoteQF /> EN-US X-NONE X-NONE /* Style Definitions */ table.MsoNormalTable {mso-style-name:"Table Normal"; mso-tstyle-rowband-size:0; mso-tstyle-colband-size:0; mso-style-noshow:yes; mso-style-priority:99; mso-style-qformat:yes; mso-style-parent:""; mso-padding-alt:0in 5.4pt 0in 5.4pt; mso-para-margin-top:0in; mso-para-margin-right:0in; mso-para-margin-bottom:10.0pt; mso-para-margin-left:0in; line-height:115%; mso-pagination:widow-orphan; font-size:11.0pt; font-family:"Calibri","sans-serif"; mso-ascii-font-family:Calibri; mso-ascii-theme-font:minor-latin; mso-hansi-font-family:Calibri; mso-hansi-theme-font:minor-latin; mso-bidi-font-family:"Times New Roman"; mso-bidi-theme-font:minor-bidi;}

Hi,

In response to your email, I will give your link a try: how to embed Storyline content into a Web page. In the interim, I attached a Word doc that describes the procedures I followed in Storyline and RoboHelp.

Thank you.

Marsha

Peter Anderson

Hi Marsha, 

Thanks for the info you attached. Unfortunately, we don't support playback of the single story.swf as a method to launch content. It does sound however, like RoboHelp is attempting to block that method anyway. Have you had a chance to discuss it with the RoboHelp administers, by any chance?