Error Publishing

Storyline was working fine until the other day and now I can't publish anything.

Here is what I have done so far:

1- uninstalled the program and reinstalled

2- changed the file name to a single word no special characters or spaces

3- change path to just desktop (short path)

4- rebooted computer

5- tried publishing files that published without a problems, same error.

I attached the file and here is the error I am getting:

 

<?xml version="1.0" encoding="utf-16"?> <ErrorReport xmlns:xsi="http://www.w3.org/2001/XMLSchema-instance" xmlns:xsd="http://www.w3.org/2001/XMLSchema"> <ReportType>Error</ReportType> <ApplicationName>Storyline</ApplicationName> <Version>2.11.1609.3020</Version> <SerialNumber /> <Enterprise>false</Enterprise> <Email>julie@stringhamschools.com</Email> <Date>2017-01-04T10:44:55.8967615-07:00</Date> <Message>Illegal characters in path.</Message> <Source>mscorlib</Source> <StackTrace>System.ArgumentException: Illegal characters in path. at System.Security.Permissions.FileIOPermission.EmulateFileIOPermissionChecks(String fullPath) at System.IO.FileStream.Init(String path, FileMode mode, FileAccess access, Int32 rights, Boolean useRights, FileShare share, Int32 bufferSize, FileOptions options, SECURITY_ATTRIBUTES secAttrs, String msgPath, Boolean bFromProxy, Boolean useLongPath, Boolean checkHost) at System.IO.FileStream..ctor(String path, FileMode mode, FileAccess access, FileShare share, Int32 bufferSize, FileOptions options, String msgPath, Boolean bFromProxy) at System.IO.FileStream..ctor(String path, FileMode mode) at Articulate.IO.Zip.UnZipFiles(ZipFile zipFile, String targetPath) at Articulate.IO.Zip.UnZipFiles(String zipFileName, String targetPath) at Articulate.Design.WebObject.UnZipLocalFilesToFolder(String zippedLocalFiles, String folder) at Articulate.Design.WebObjectPublisher.a(IPlayerService A_0, IStageWebObject A_1) at Articulate.Design.WebObjectPublisher.CreateStageObject(IPlayerService service, IStageWebObject webObject, Int32 depth) at Articulate.Design.Shapes.WebObjectShape.CreateStageObjectInstance(IPlayerService service) at Articulate.Design.Shape.CreateStageObject(IPlayerService service, bwSlideBase slide) at Articulate.Design.Shape.GetStageObject(IPlayerService service, bwSlideBase slide) at Articulate.Design.Shape.Player.IPlayerShape.GetStageObject(IPlayerService service, bwSlideBase slide) at Player.PlayerWriter.l(IEnumerable`1 A_0, bwSlideBase A_1) at Player.PlayerWriter.l(IPlayerSlide A_0, bwISlideContainer A_1) at Player.PlayerWriter.WriteContent(IPlayerContentProvider contentProvider, Boolean merged) at Player.PlayerWriter.Write(IPlayerContentProvider contentProvider) at Articulate.Design.Publish.TargetContext.PublishBackgroundWorker.OnDoWork(DoWorkEventArgs e) at Articulate.ComponentModel.STABackgroundWorker.a(Object A_0)</StackTrace> <FlashVersion>WIN 24,0,0,186</FlashVersion> <PrivateMemory>118,908 K</PrivateMemory> <VirtualMemory>643,348 K</VirtualMemory> <OSVersion>Windows 7 6.2.9200.0</OSVersion> <CLRVersion>4.0.30319.42000</CLRVersion> <FreeSpace>C:\: 678514057216
E:\: 0
W:\: 375300599808
X:\: 0
Y:\: 605296652288
Z:\: 605296652288
</FreeSpace> <ProcessorCount>2</ProcessorCount> </ErrorReport>

4 Replies
Alyssa Gomez

Hi there Julie,

I'm sorry to hear you're having this issue with publishing your file, and it sounds like you've already tried everything I would have recommended. The only thing I would add is to try to import the slides from the original project into a new Storyline project. I tested that with your file, and unfortunately that did not work either. 

At this stage I would recommend reaching out to our Support Engineers directly over here so they can investigate with you to get to the bottom of this as quickly as possible. Be sure to share your case number here with us so we can follow along and relay helpful info in this thread for anyone else in the community that may encounter the same problem! :) 

julie g.

I found the problem. I backed up my project folder to a usb and started working from there, thats what caused the issues. all the ones working were done from my desktop. I have created 3 project from that location. Is there a way to fix the files once I moved back to my local drive? Just moving them didn't work, it would save me a lot of work if I could just repair these somehow

Alyssa Gomez

Ah, that would explain it! So you're saying that you saved the files that were on the USB drive to your desktop, and you are still unable to publish? It sounds like the files may be corrupt, but there may still be a working version of your project in your temp files. Here's how to check:

  1. Open this folder in Windows Explorer: %appdata%\Articulate\Storyline.
  2. Scan the contents of this folder for a file that starts with the name of your project.
  3. If you find the file, copy it to your desktop (if you find more than one, copy the latest version).
  4. Change the file extension of the copy on your desktop from *.tmp to *.story.
  5. Double-click the file to open it in Storyline.

If that doesn't work, I would recommend contacting our Support Engineers directly so they can help you troubleshoot further.