Error reporting progress to LMS

I had a course last year that worked fine.  There were a few minor changes to it for this year.  When I view the published course, everything is fine.  Once the course is loaded to our LMS, it starts and runs fine, but if you exit at any point (including after completing the final quiz) the LMS returns an error.  I've tried everything I can think of including creating a new Storyline 3 file.  Same error.

16 Replies
Leslie McKerchie

Hi Alison,

It looks like your email signature came through when you replied via email. You can remove that if needed by clicking ‘Edit’ beneath your response. Here’s a quick Peek video if you need help.

Your image/attachment did not come through to the forums either, so I'm still unsure of the error you are seeing.

Are you experience the same issue with SCORM Cloud as well or is this only happening in your LMS?

Crystal Horn

Hi there, Alison.  Thanks for the reply and for troubleshooting in SCORM Cloud.  Super helpful!  Here's what I would do:

  • Touch base with your LMS support/administrator and let them know about this error, and that it isn't happening in SCORM Cloud.  They may be able to give insight into what the LMS is trying to tell us.
  • If they're able to give you some helpful information, but it points to an issue with the output, feel free to reach out to our support team.  

    Tell us about how the course launches (in a new window or within the Moodle window), and how the course is being exited.  Is there a button?  Does the learner just close the new window?  Also, is the course accurately reporting completion and success status?  Lastly, be sure to share your .story file with us for testing!  It's the best way for us to narrow down what's happening with the setup as you use it.

We'll be ready to help!

Alison Coops

I'm checking with my LMS admin so see if she can offer any guidance. The
course launches in a new VLC window. It doesn't matter how the course is
exited; all methods lead to the error. It seems to be a problem reporting
progress because the problem occurs whether exiting from slide 2 or after
passing the final quiz. If my LMS admin isn't able to provide any helpful
information I'll share the story file.
Thanks,

*Alison *

Whitney Miller-Nichols

I'm having this same problem. I spent a significant amount of time on the phone with our LMS provider (Torch) and it is not a system issue.  I did NOT have this problem with courses exported to SCORM 2004 in July-Sep 2017. This batch of courses was exported to SCORM 2004 in May-June 2018.

I have a user right now who logged out about halfway through a longer course and is trapped on the slide she stopped at -- she can't navigate forward or backward because of navigation restrictions and if she goes back to the beginning of the course it will reset her progress. She made it to this point on an iPad. I have another user who is in the same predicament and launched the course on desktop. Both users were on wifi with continuous connection. 

 

ETA: The courses I'm having an error with were authored in Rise. It's possible my Storyline courses are having problems too, but I haven't had anyone report an error yet.

Katie Riggio

Hello, fellow Virginian. Appreciate you circling back with this insight! 

I see my teammate, Michael, tested your project where he was also unable to replicate the issue in SCORM Cloud. While we're glad to hear that revising the content helped, this is not behavior that we would expect you to have to go through!

If you come across this roadblock again, another option is to enable LMS debug mode to capture the communication flowing back and forth between your project and LMS. This data can help your LMS team quickly nail down the culprit. 

 

Hi there, Whitney! Very sorry you're experiencing a similar issue with your Rise courses.

I created a case on your behalf for our Support Engineers so we can investigate this behavior with you. Somebody from the team will be in touch with you directly, and I'll follow along as well – we'll get to the bottom of this together!

Whitney Miller-Nichols

Hi there -- It's me again. I'm having the same problem again, even after I made some changes to the course navigation (free navigation, though quizzes must be passed before the user can progress) and changing the end of course trigger to a Storyline block. I had someone report the same error today with the new version of the course.

He said, "I cannot get past the quiz for Lesson 29. I have gone through it at least three times today and I have made 100% each time but I am still not able to proceed to Lesson 30. When I re-launched initially today, I was on Lesson 30 but I went back to the quiz just to make sure I was on the right lesson. Once I went back to the quiz I haven’t been able to get back to Lesson 30."

In a follow-up email, he said, 

"I am taking the course on a desktop running Windows 10 64 bit on a LAN using the Chrome browser.

 I’ve been in and out of the course several times and I’ve never had a problem until today.

 I went back and re-took the quiz again, for the fourth time today, and still get the same message. I rolled back to lesson 28 before I took it this last time.  Here’s a screen shot:" [attached]

I had no problems with this course in SCORM cloud, and I've run it in the LMS in debug mode and have not been able to replicate the problem. I THINK this is where my other users were running into problems, but I can't be sure.

Any ideas? 

 

Katie Riggio

Hello, Whitney. Appreciate you circling back on this!

First, it's good to hear the navigation works correctly on SCORM Cloud. That tells us that there isn't a navigation issue in your Rise 360 course.

Now, let's tackle what's happening in your latest report. Could you let us know:

  • Are you still using the Torch LMS?
  • In your user's email, he mentioned he's using Chrome. Do you know what version he's on? I'm also curious to know if he runs into this roadblock on another browser.
Whitney Miller-Nichols

Yes, still using Torch LMS. Interestingly, the course behaves correctly in the staging site (and SCORM Cloud, as mentioned), but misbehaves in the production site. 

I don't know what version of Chrome he was using, and I don't know if he tried switching to a different browser. 

This is what he told me in a follow-up email this morning: "I am able to proceed to Lesson 30 this morning but when I initially re-launched I was sent back to Lesson 10. I just went ahead and re-took all of the quizzes and I was able to advance this time." He was able to complete the course this afternoon without any more glitches.

This morning, I logged in to Torch LMS as the user in question and navigated to the point in the course that he had the error (lesson 29/quiz). I followed his reported behavior: finished the quiz at Lesson 29, advanced to Lesson 30, closed course. Relaunched course. It opened on Lesson 30. I backed up to Lesson 29, then back again to Lesson 28. As you can tell from Screencast #1 (link below), all progress in the course has been wiped. If you watch Screencast #2 (link below), you can see that the user is “locked” on lesson 28 – he can’t navigate past Lesson 28, even though he has previously completed Lesson 29 and started Lesson 30. He CAN back up to the beginning and/or the lesson closest to the first quiz and start over (Screencast #3). However, that’s not good customer service on our end. 

I've sent all of this information to support at Torch LMS and they are investigating.

Screencast #1: Course behavior when relaunching and backing up to a previous lesson: https://360.articulate.com/review/content/ba7f5ce7-8f5c-4321-918f-32470d71974f/review

Screencast #2: Showing that user is “locked” on Lesson 28: https://360.articulate.com/review/content/d3e15ed0-dc26-486a-9516-57360863e798/review

Screencast #3: Showing that the user can back up to beginning of course: https://360.articulate.com/review/content/e669f382-e6b7-45b6-923e-047cb8a61377/review

Screencast #4: Showing that course behaves correctly in Torch staging environment: https://360.articulate.com/review/content/b0550214-003a-4f56-b163-493dd4a9d48d/review

Katie Riggio

Good morning, Whitney! 

Thanks for sharing these stellar screencasts and for keeping us in the loop. I hope Torch gives you insight into why this oddity only happens on their production site.

If they're able to track the source of this issue and it points to a problem with our output, feel free to reach out to our Support engineers here. We're on stand by, ready to help.

Good luck, and do let us know!