Failed statement when it's not suppose to be

Hi!

I'm using Grassblade LRS to use with Learndash within our WordPress website. When I first tried to test a simple course (true/false question +  a result slide - TinCan export, result slide selected), everything worked fine and the statement sended to my LRS was good.

 verb : { 
id : http://adlnet.gov/expapi/verbs/passed
},
result : {
duration : PT0H0M5.51S,
completion : true,
success : true,
score : {
scaled : 1
}

Then, I tried to upload my 700mb course with the same publish setting. In that course, there's three different result slides, but the last result slide is the only one that I want to get the result from (the other two first result slide is only informative for the user).  But when I test my course, my LRS got only a "failed" statement from the result slide, even if the statement of each question linked to that slide got the statement "passed". The JSON file show that information :

{ 
version : 1.0.0,
result : {
success : false,
score : {
min : 0,
scaled : 0,
raw : 0,
max : 7
}

Why my course send a min/scaled/raw/max information (with no value in it) instead of a "completion:true" statement like first my test ?

I really need your help with that issue! Thanks!!!

3 Replies
Alyssa Gomez

Hello there David,
 
To confirm it's not an issue with your LRS, you may want to look at testing it in another environment such as SCORM Cloud. The article linked there will walk you through testing steps and help see how it'll behave in another environment. Keep us posted on how your testing goes, and we'll investigate further if you're seeing the same behavior there. 
David Guillemette

Oh, nervermind... I did just realize that the company who made our course ended it with a slide who was not the final result slide (which was hided in a backend scene). So, in the end, the learner could see his result, but Articulate was unable to confirm to my LRS that he had completed it.

Problem solved :) Thanks !