Fill in the blank does not work on even numbered views of the slide

I created a Family Feud type game in which the user types in answers in a Text Entry Field to answer the questions. The first question has 6 answers and works fine. The second question has a single answer and works fine the first time the game is played. I have a Replay button at the end that sends the user back to the first slide. On the second (4th, 6th, etc) time through the game, the second answer is marked incorrect as soon as the slide begins. However, on the third (fifth, etc) time it works correctly. Any one have an idea why this happens on even viewings only?

https://files.itslearning.com/data/2517/c272/valentine%20family%20feud%20game/story.html?

4 Replies
Alyssa Gomez

Hi there Dennis!

Thanks for sharing the link with us - very cool Family Feud game template!

It might be helpful if you could share your .story file here so the community can take a closer look at what might be causing the issue. If you don't mind sharing your file, you can use the Add Attachment button at the bottom of the reply window to attach it directly to this thread.

Dennis Gifford

I was able to find the problem. I was resetting the Text Entry to blank for Question 2 on that slide. It appears that the second time through, Storyline was registering the incorrect answer before it reset the Text Entry. When it registered the answer as incorrect every even numbered time, it then cleared the Text Entry, so it would work the next (odd numbered) time.

I moved the reset trigger to the beginning slide and it solved the problem.