Fill in the Blank using Freeform Pick One

This is a multi-part question. The attached is a sample interactive from an accounting course. 

First issue: The user plugs in values in the blank number fields, then clicks Submit to get the calculated EFN. The first slide uses Freeform Pick One, with Correct and Incorrect buttons offstage. Ideally, if the user enters any incorrect value, the Incorrect feedback displays. If they're all correct, the Correct feedback displays. 

When I test it out and put in all the values, I get the "Invalid Answer - You must complete the question before continuing" window. So, I made a second version without the Freeform format, and made my own Submit button with triggers. It works correctly.

Second issue: Both slides have 7 numeric fields, but they don't keep their format when published. They all default to black borders with white fills. I was wanting them to have no borders and light blue fills. In the first slide, I made the table white fill/black border and the numeric fields light blue/no border. In the second, I made the table light blue fill/black border and the numeric fields no fill/no border, hoping that the table's fill color would show through, but that didn't work either.

3 Replies
Alyssa Gomez

Hi there, 

Thanks for including your file! Happy to investigate these issues with you.

  1. Invalid Answer Layer appears - This happens because the "Submit Interaction" trigger is on top, which means it happens first. Use the arrows at the top of the trigger panel to move it all the way to the bottom of the trigger list. That should solve the issue!
  2. Numeric fields have incorrect formatting - I'm not sure why the numeric entry fields displayed with the incorrect background color. In any case, I was able to fix it by inserting a new numeric entry field, formatting it with a blue fill, then using for Format Painter to apply the fill to the rest of the fields. 

Check out Slide 1.1 in the attached file to see the changes I made, and let me know what you think!

R. Eric Smith

Thank you so very much! I'm glad it was a simple fix.

One more question: in the trigger for the Correct button, I have conditions that all the numeric entry fields must have a specific value. One of these is 0.078, which rounded to 0.08 in the Trigger Wizard. Is there a way to keep it from rounding up? Accountants frown on these things. :-)