Font Change within a Text Entry Field

Jun 26, 2012

No matter what i do to the font and font size of the text within a text entry box, it always reverts back to the Articulate font, 12 point.

I've already noticed there are two ways to edit the font: You can click on the box and change the font, or you can edit the text and then change the font.

I've done both and every time it reverts back to Articulate 12pt.

Is this a bug?  What's the work around?  Highly annoying!

195 Replies
Ashley Terwilliger-Pollard

Hi Bryan,

I don't have an update yet - but it is something that we've passed along to our Quality Assurance team. If you'd like to also reach out to our Support Engineers we're happy to take a look at your specific file/issue and ensure it's the same as detailed here (there are a few different ones in this thread). You can connect with our Engineers here. 

DJ, I know you're also working through a case with Emily and that some of it has been associated with working off a network drive so that'll want to be something you double check going forward after your IT team reinstalled Storyline. If you continue to have difficulty please feel free to respond to her emails directly as well as reaching out here in the forums. 

DJ Trent
Bryan McD

When you say it changed nothing for you, why should I bother to
uninstall/reinstall...or am I misunderstanding you.

You are not misunderstanding, other than support will not move forward on this issue unless you uninstall/reinstall. It appears that MIGHT work some of the time so it's the first hoop you have to jump through. 

For me, it did not work. 

DJ Trent

Everything has been on my local drive since Emily told me I had to move everything there. It has not helped in any way, other than to give my IT guys heart-burn. So I think "associated with" is a bit of a misnomer. 

And just to complete the thought, everything was on my local HD before it was uninstalled/reinstalled. And we did reboot between. So I think I've touched all the bases I've been instructed to touch.

Emily Ruby

Hi Bryan!

This thread has several issues reported, can you please let me know which one you are seeing? I can see that the issue DJ Trent reported was reproducible, and we have an open case with our QA team. It seems to happen when clicking inside the text entry boxes in the screen recordings.

I can definitely reach out to them to see if there are any updates.

If you are experiencing one of the other issues mentioned in this thread, would you  share a file with me directly?  I would be happy to take a look and see if we can sort out what is going on, and hopefully reproduce it from our end. You can put my name in the case submission.

Sandy Mason

OMG I'm working on a large project with quite a few number variables and this issue was driving me insane using Storyline 2 as I ended up with 2 different styles and colours intermittently.

I tried your wonderful ideas mentioned above however for me I found this combination worked... finally!

  • Select inside the number variable box
  • change font style, size and colour
  • this changes the box to a broken line
  • select the box again (so it's a solid line)
  • change font style, size and colour again
  • this changes back to a solid line
  • right click and select 'set as a default text box'
  • in the timeline lock it
  • review your slide and your changes should be what you want

In terms of adding the next number variable after select 'set as default text box' this doesn't seem to work.  I had to use this process for every number variable.

Kate Niblett

I am not having trouble with font size but colour. I am replicating an existing IT system and where the learner needs to add text the box is dark blue so there answer needs to be in white text. I've tried all the fixes above and none of them seem to work. I'd like to keep the text box dark blue so it looks like the system learners are working in - but the text keep reverting to black. Has anyone else found a solution?

Conor Twomey

Hi Kate, try this it works for me.

I had generated a try me simulation of our SAP order entry system, which has a lot of user entry fields.

Problem definition:

Each data entry field defaults as a big white box 554px high by 1336px wide and needs to be a small yellow box, 16px high with varying widths from 20px to 120px. When you get to the slide in the simulation that contains a text entry field, the cursor needs to default in the box, you should not need to click it, and when you type text, it should fit and not change the size of the text/data entry field, or wrap the text upwards out of sight.


Grab the first slide from your simulation that has a text entry field that is misbehaving and save it to a new storyline module by itself. Delete the misbehaving text entry field and add a new one using Insert > controls > data entry > text entry field. Give it all the attributes that it needs to work correctly and preview the slide. You will need to click into the text entry field but otherwise it works/looks correct. Save the file as a “solution for the bug”. Then copy into this file all the slides from a misbehaving simulation and reset one of the big white boxes to the right size, shape, and color. Then check that slide in the preview mode and you will discover that it works correctly.

You still have to manually change all the system generated data entry text boxes, but they work correctly after being changed.

See attached my example “solution for the bug” the first slide is the one where I “Delete the misbehaving text entry field and add a new one using Insert > controls > data entry > text entry field”, the second slide is a slide that I copied into it and just adjusted the Storyline generated white box to the “right size, shape, and color”.

The great thing is that you don’t need to re-record the simulations you can grab any buggy storyline module and copy/paste them into the “solution for the bug” file and they start to work correctly.

M. Bosscher

I started this thread over 3 years ago, and Articulate still hasn't figured this out. I get notified of a post here a couple times a week so it's still effecting people.  Nice work Articulate. 

For those curious what my workaround has been? Avoid text entry boxes. Just need to design my content with that in mind - and I know this is an option for most people but I will populate the field for them with a text box animated to wipe reveal and add some caption "The parameter has been entered for you, click the SUBMIT button to blah blah blah"

Terrible solution, but I'm done fighting with text box formatting. 

Sandy Mason

Hi M

Yes I'd seen the available threads for viewing dating back years and kind of wish there was a end result slide of sorts identifying type of issue (text box entries) and best possible solution (best not to use) for now while Articulate consider it for their next update... and now I won't hold my breathe.

Thanks for your response M, I shall consider using what you suggest but will need to try to work around providing an great interactive simulation as best I can.

Maggie Cowan

Agreed. This issue causes me to either exclude text entry boxes from simulations or use another software to produce a simulation.
This email has been scanned for email related threats and delivered safely by Mimecast.
For more information please visit

Paul Dracos

Brian & Maggie, 

You know, my grand daddy used to say that the "talk is cheap, if you want truth, watch the actions". Could not be more true in this case. Everybody yaps about customer service, but this is the truth, the action, or lack thereof.

On a separate note, is it just me or did everybody have to upload a new avatar before they could post? Even though this is my original avatar and was visible in all my other comments on this thread, I still had to "upload a new avatar to post". 

/shakes head

DJ Trent

Conor - No, that did not work for me. I tried it on a subset of a scene but it only worked once, then failed. I appreciate the effort but for several hundred slides, that is a prohibitive amount of reworking even if it did work every time. 

With all of these issues in mind; the fonts changing, huge numbers of slides resetting to an AFT of 0/0, or 0/1, or whatever frame number and -1; requiring I hand tune over 30% of my slides;  I had a heart to heart with my boss and we have decided to eliminate Articulate from our production cycle as much as is possible. We will use a different approach and a different piece of software going forward.

The end product will not be what I was planning, but using Articulate I cannot produce what I want, and what my customers deserve. 

Alison  L.

So after this issue reared its ugly head, I wound up here. I tried all ..what are we up to?.. like FIVE things. And nothing worked (and my is going from Calibri to Times New Roman). 

BUT.. Happy to report that after PUBLISHING the file and looking at THAT,  the problem is resolved. ( And of course, can't manage to replicate it again. )

I hope that helps the next person.



This discussion is closed. You can start a new discussion or contact Articulate Support.