Having problems with the "Jump to xxxx" Action

Sep 24, 2020

I'm having an issue with the attached .story file.  FYI...I've removed content not related to the problem, two buttons and corresponding layers, so that's why the flow may seem a bit odd.

This is the first time I've used the "Jump to time/cue point" command and it seems to be working well. 

However, I've set it up so that once the learner selects all three buttons on the "Key Personnel" layer it's supposed to jump to  cue point #7at the end of the timeline to show the "Got it" button and let the learner end that layer.  Instead, it seems to be jumping to 45s on the timeline and plays that section of the timeline (containing the Renee_11_Super_mp3 audio) in a never ending loop.  

It does this whether I say to Jump to Cue Point #7 or to 98s on the timeline (I tried both).  

If anyone has any ideas about what's happening I'd appreciate the input.  




4 Replies
Sam Hill

Hi Jay, I'd take a different approach and use the media events. You could still use the visited states of button, but it depends if you want to push people through the audio, or just allow them to click each button. I've demonstrated a custom "Completed" state which is set when the media completes.

Walt Hamilton

It seems intuitive to me that the order of these two triggers should cause a problem:


If the first one pauses the timeline, then I'm not sure the second one will be evaluated. There are three of them, and when I changed the order of all three, the loop stopped.

I applaud your desire to learn and use jump to triggers, and it looks like the triggers should work, so there is something pretty subtle lurking here that is causing the problem.

Instead of these triggers,


you might try jumping to cue 7 when the audios complete, if the buttons are visited.  When I tried it, and put a seekbar on the slide, so I could see what is happening, I found that the seekbar acted like I expected for the first two buttons, then acted strangely for the third, no matter what order I clicked them. That to me sounds like either a bug, or a corrupted element.  That means either rebuild the entire slide from scratch, or eliminate one object at a time until you find the corrupted object.

It looks to me like you have spent quite a bit of time troubleshooting this, and it looks to me like it would take me hours to find what is wrong.  I'm not willing to do that, when I see what seems to be a much simpler method (and the simplest ways are always the best). If it were mine, I would copy everything from the layer to the base. I would pause the timeline until the first button is clicked, then make the menu visible. At that point, when each button is clicked, I would jump to a layer. It would be pretty easy, since the audio is already divided. Set each layer to prevent clicking on the base, so two audios don't play at the same time, and hide each layer when the audio finishes. when each audio finishes, show the Got It button if all three are visited. When it is clicked, resume the timeline on the base, and jump to the next slide when it ends.

Hoping it goes well for you.

This discussion is closed. You can start a new discussion or contact Articulate Support.