I need to upload an archive copy of a Storyline 3 project to our SharePoint system. Failing that, I need to upload the project containing a portable player.

Hey Heroes,

1. Saving an archive copy:

A former colleague uploaded archive copies of our Storyline courses before leaving and I now need to update them. She says she did not upload the .story file but the "storyline source" file - which she has not specifically identified. :/

When I look at the file properties in the Storyline Archive folder, I see "<course name>.story" (please refer to 1st attachment below).

Additionally, she separately uploaded our courses and our course graphics to the general Archive folder. When I look at the properties there it shows "<course name>.mbz (please refer to 2nd attachment).

Unfortunately, when I publish a project to my computer it is missing the "analytics-frame.html" file and the ""story_html5.html" file.  This may be due to our system being set to save to our Cloud, not the local drive. But when I do bypass the Cloud and save to the C drive, I still get the same problem. I have tried saving to LMS (as recommended by my predecessor), to CD and even to Web. Still missing those files.

2. Saving for others to view (w/portable player?)

I recall seeing this as an option under one of the choices; Web maybe? If I can't save an archive copy, would it be possible to save a viewable copy on our SharePoint system? If so, which option do I choose when publishing?

This was a lot, but the Articulate Heroes have always come through for me in the past. Thank you in advance for any assistance/guidance you can provide!

5 Replies
Leslie McKerchie

Hi Richard,

Thanks for reaching out and sharing with us what you are currently working on.

1. Based on the image and description you've shared, it looks like you have the .story file, which is the file that you would need to edit/modify the project in Storyline.

A .mpz file seems to be a Moodle backup file of some sort, which may be the zipped published output if it matches your course name of the .story file.

  • Are you opening the .story file in Storyline 3 to re-publish?

We simplified the published output in Storyline 3 builds 3.10.22406.0 and later. When you publish HTML5-only or Flash-only courses, Storyline no longer generates the following files in your published output:

  • index_lms_flash.html
  • index_lms_html5.html
  • story_flash.html
  • story_html5.html

You'll only see the files above when you publish courses with both HTML5 and Flash formats.

2. I'm not sure what you are referring to when mentioning a 'portable player'? If you could elaborate on that, we'd be happy to help.

Richard Maloney

Thank you for responding, Leslie.

The refence to "portable player" is invalid - I'm not publishing to Web.

The following is lengthy but may help you see what I'm doing (incorrectly) and possibly assist you in helping me.

To avoid problems, Articulate says we should only work from our local (C:) drive when publishing so I download the "course name".story file from SharePoint folder to my C drive:

SharePoint properties display this as a .story file.

Once downloaded, the file opens the course for editing in Storyline on my laptop:

I complete the following:
• change the graphic on one slide.
• remove a line of text from another slide
• fix a new glitch (did not exist in any of our work environments): hyperlink overlapping the text on a slide:

I save the changes and select Publish - LMS, and to my C: drive, using the settings my predecessor successfully used a month ago. (Publish setting in attachment.)

I leave Reporting settings as they are by default and ensure Track using quiz results is selected on the Tracking tab:

I select OK in the Reporting and Tracking Options window and select PUBLISH (to my C drive). My result is always missing the "analytics_frame.html" file that my predecessor always had in her published results. 

I use the ZIP option in the Storyline post-publish options window, then upload the zip file to one of our online work environments as a new activity/resource in a new test course. I inevitably see this error:

"Incorrect file package - missing imsmanifest.xml or AICC structure"

I have also tried replacing the zip file in an existing test course with this zip file and get the same results.
I am hoping someone can see what I am doing wrong and provide some guidance.
Thank you in advance for your time and expertise!