Importing translations

Jul 06, 2022

I have tried importing a translation xlf file and for some reason it doesn't work.

I have also tried importing the SL file into a new one and then importing the translation. That didn't work either. I have also tried renaming the documents.

Has anyone had the same issue and how did you solve it? 

I have added a screen recording of the error as well as the SL 360 source file and translated xlf file.

2 Replies
Thor Melicher

Hello Tanya,

These types of issues can be really tricky to solve as it's usually a malformed XLF file that causes the issue you're seeing in Storyline.

I did a quick analysis and I noticed that if you bypass the error messages displayed, you'll see that the translation occurs up to slide 1.5 where the title on the slide is translated but the remaining text is not...  So, this is where you would want to start looking.  It may not be the only problem in the file but at least you have a place to start.

So, the $20,000 question, how does one go about fixing this?  Unfortunately, it's not easy.  Here's a process that you can try:

1. First, re-name your file's extension from .xlf to .xml.

2. Open your browser of choice and then drag and drop the newly renamed .xml file in.  This will then display the file in a more readable format (Storyline's formatting doesn't use whitespace which makes it difficult when opening in a simple text editor.  There are other applications that can make XML easier to read and edit but for now, this is a good place to start.)

3. Now that you can see it better, search for this string 5ud3dMGpoNP.  This is slide 1.5 where the error is - I just looked at your slide for the unique text "1st cartilage ring" and searched for it. 

4. Going line-by-line, you have to check to see if the source section matches the target section in the order/placement of the tags.  This is where it's hard because usually it's off just by a little and it's hard to find.

5. Once you find the error, you'll then need to fix it in a text editor.  Notepad will work but again the whitespace issue will make it more difficult to edit but it can be done.

I've attached a file that may help you out, I have your XLF file properly formatted with a translation provided by Amazon Translate from an application that I wrote.  I'm not allowed to promote my application so I can't tell you the name of my application (Articulate forum rules). 

Instead of going with my translation (you could but you would want to verify it), you can use the file to help do spot checks to see if you might be able to find the problem faster.

Some quick notes - there is more 'tag text descriptors' in your XLF because it was most likely done in a CAT (Computer Aided Translation) application intended for other purposes than just Storyline.  My translation adds whitespace which makes it much easier to read even when opening in Notepad.

Other steps you could take so you don't have to go this alone:

  • Go back to the translator and ask them to check the slides starting at 1.5.  This might help them isolate where their program structured the tag(s) incorrectly.
  • Wait for the Storyline moderators to respond. I've seen them request XLF files to see if they can figure out where the problem is.

I hope this helps you track down the problem - good luck!