Inconsistent undo functionality

Hi guys,

Has anyone else been having trouble with undo not working as expected? On a regular basis, I find that if I try to undo a mistake I've made (ctrl +z), not only is this action not undone, something else entirely unrelated happens instead!

An example of this is, more often than not, instead of my last action being undone, I'm transported from the slide I'm currently viewing to a completely random slide in another scene. Now this is nothing more than a mild annoyance, but a more disasterous example of undo not working is when it either "undoes" an action several steps before the one I want to do OR develops a mind of its own and deletes items of the stage!

This has happened to me today on numorous occasions. The most recent (and worst) being when I accidentally pasted a text box on to the wrong slide. When I tried to undo this by pressing ctrl + z, Storyline didn't undo the paste, but instead deleted 1 image, 5 text boxes, 5 hotspots, and unformatted 2 other text boxes on the base layer.

This problem has me tearing my hair out. I'm having to redo chunks of work that are getting randomly undone or ,worse, deleted.

Andy

16 Replies
Bruce Graham

The current "Undo" function, especially when graphics have been moved, or sized since the last save is virtually un-useable.

Sorry - but that is the case.

It virtually scrambled a course of mine over the weekend, making 10-minutes of relatively complex graphics manipulation disappear, dumping me back onto a completely different scene just to add insult to injury.

Just submit a case where it can join all the others

Dear Magnus - hear our pleas.....

Bruce

Brian Allen

Phil Mayor said:

Undo is a difficult function to debug, and also difficult to report.  If you have a reproducible undo bug let them know.   I avoid undo like the plague, unfortunately I have now got so used to not using it a fixed version is likely never going to help me!


Agreed - I recorded a screenr and provided my story file, and customer support was still not able to repro the problem on their end of things. 

Simon Perkins

Catherine Conley said:

I just upgraded to version the Dec. 14th release. I am now having a ton of trouble with the undo button. Like mentioned above, the undo function is unusable. Storyline seems to randomly decide what the last action was - even if it was 10 actions ago. 

 Any fix?


I actually find the Undo in the latest release to be even more buggy than previously.  Initially it seemed better (throughout beta) but now it's back to doing the same as before; random slide jumps, text turning white, text formatting going weird, etc.  

Bruce Graham

Sad to say but agree completely - it did appear to be stable in the Beta, now it is terrible (again).

For me, it seems to happen the most when working with images - it seems to be relatively stable with text.

Here is why, IMHO, it is such a problem...

"Undo" is not used in (my) the real world by designers just when they screw up, it's used when prototyping, "playing" with design. I will move an an image from A --> B, or change a font. If I do not like it we (I) use CTRL-Z. I've been doing that since Day 1 of it being available, on every other application I have ever used.

I do not design/build applications, so I do not know how the task of mending it will be; unfortunately - as worded above, it is un-useable - not good for a production version that has had a fix update.

For those of us who live and die, every day, building courses, uploading every course and submitting bugs where this happens is a completely impractical method of solving the problem - it would be every course I build.

I do not quite know how to take this one any further, or whether there's even any point discussing it. It's broke. Please let us know when it isn't.

Thanks

Bruce

Karyn Lemberg

OMG!- wish I'd known about this bug earlier. Just started working on my first big 'real' project and wondering why I kept getting sent back to some earlier slide - but it was just small things.

It finally got to the point where I clicked CTRL-Z as I've always done in every software program and almost had a heart attack because the entire days work was gone! It went from slide 28 back to slide 11... !!!!  Deleted them! gone!

After some tedious moments, I bravely tried the 'redo' arrow... and whew - I got the slides back.

Now I need a drink though.  

Has anyone got any answers on this yet?