Issue with Triggers and Variables

Hello,

I have a slide with 3 buttons. This slide has a trigger setting the Next button to be disabled with the timeline starts if the variable "Lock1" is less than three. 

Each button leads to a new slide with multiple layers. On the final layer, +1 is added to the variable "Lock1". I have tested this on the Articulate Online review platform in all browsers. It was functioned correctly. I have also tested on SCORM Cloud, also functions correctly.

When my client tests from either site in any browser, they can not get the next button to become active. I am at a loss as to what would cause this. Obviously it is an issue on the client's end.  I don't have access to their system.

Can anyone suggest some troubleshooting ideas? Could this be caused by the new Articulate 360 updates I downloaded earlier this week? Could it be a Flash issue?

Thank you!

Carrie Ann

2 Replies
Phil Mayor

Probably not a fault at the clients end, this is normally something wrong with the slides or the route the client is taking through the course.

Not the best solution, what happens if the user goes through the same section 3 times?

Perhaps when the are reviewing the course they go through each section more than once? or are returning to the menu screen another way thinking they have finished the section.

I would have three T/F variables one for each section (S1, S2, S3) all set to False.

At the end of each section set S1 etc to True.

On the menu slide set a trigger to change next to normal if S1 and S2 and S3 = True.

Also trigger order is important so maybe it is not setting the variable properly