Issues with drag and drop

Hi all

I'm hoping someone can help me - I'm completely stuck as to why my drag and drop is behaving like this!

My drag items are in the top half and my drop items in the bottom half. The drag items have a state of normal and drop incorrect. If the user drags an item to an incorrect drop target then it changes states to drop incorrect. If the user drags the item back to the top is should change it's state back to normal (I have created a hotspot underneath all of the drag items to enable me to create this trigger).

However when I attempt to drag a drag item back to it's original position at the top for some reason it is centering all of the items and not putting them back into their original position. 

For drag item options I have selected: Return item to start point if dropped outside of any drop target.

I have tried all different drag item options including having nothing selected but the behaviour remains the same. I really can't seem to figure our why it is behaving this way and would appreciate any help! 

Please find the files attached.

Many thanks

Shelley

4 Replies
Emily Ruby

Hello Shelley,

You may need to add a separate hot spot under each drag item so that when you drag it back to its starting spot, it will center within that hotspot. I have added this to Ship and Boat Hook. When these are dragged back, the state is normal.

Also, the drop incorrect state changes will happen automatically, so there is no need for the trigger to have these change. 

Shelley McKay

Dear Emily - thanks so much, that worked. It's just very odd because I basically copied that slide from a different quiz that I have - and that one works completely fine with the one big hotspot - the shapes do not snap to centre. 

Anyway this is working as I hoped now so many thanks for your advice!

Best wishes,

Shelley