Latest update (3.10) breaks drag and drop interactions when published

So I updated to latest version of 360 today, made some minor changes to a slide a and republished. Now both of my free form drag and drop interactions that were working swimmingly are broken. Changes made prior to publishing were unrelated to these slides.  The course was originally created in a previous version of SL360. 

Seems to be a problem  with changing object states and also the "when shape stops interacting with x" triggers. Shapes are also "snapping back" into their original position even when dropped on correct shape.

And now a course that was set for stakeholder review is back in development until further notice, and I'm in the position of recreating these slides from scratch and crossing my fingers that it actually works.

UPDATE: Recreating the slides from scratch did not work.

 

7 Replies
Greg Hagar

 These are just a few of the things I've witnessed since trying to isolate the problem. Keep in mind these issues appear when creating a new slide from scratch:

  • When a drag object is changed to another object in the slide properties, both shapes are  draggable. This persists even after closing storyline and reopening.
  • Using hotspots as drop locations doesn't work anymore (did previously)
  • Change state to "hidden" when object dropped on target no longer works
  • Objects that contain additional objects within their states (think of an image object with a text box pasted inside each object state) do not change states when dropped on the target. This worked in previous versions as well.
  • Objects snap back into place seemingly at random, regardless of whether they're dropped on the correct target or not (seems more likely to happen when the object is dragged over more than one target before being dropped).
  • You can now select a group as a drag object - I don't know if this is a newer feature or not (I don't recall being able to do this previously, hence all the pasting objects into states rather than just grouping them) - in any case, when a group is selected as the drag item, the slide simply won't render on preview (just a blank slide with the the 'spinning' cursor).

 I should add that this was a new slide in project created using the previous release of SL360. I'm going to see if I can replicate in a brand new project or not.

Greg Hagar

Thanks for the demo Wendy.  My original file is definitely still causing all sorts of problems since the update. Not sure if the update really had anything to do with it the corruption or not, but it was quite a coincidence to say the least.

After seeing your video, I tried creating the drag and drop in a new file and it's all working perfectly now.  Yesterday was a long day, and I by the time I start trying to reproduce some of the errors I was seeing in my original file, I might have been getting a little sloppy constructing my triggers in the new file.

Anyway, thanks for providing the opportunity for a sober second look. I feel much better now :)

Greg

 

Greg Hagar

I spoke too soon!

I started rebuilding the slide as before and it was all going well until it suddenly wasn't!!

I was adding elements and testing them 1 at a time and the states were changing to hidden when dropped as expected. And now they just aren't anymore.  It occurred after introduced a state change on the drop target as well. Undoing doesn't change it back. Closing without saving and starting over doesn't bring it back. Adding new drop targets and recreating triggers doesn't bring it back.

Recreating a new "drop object" from scratch does seem to work, but copies of the original drop object don't.

So while the problems I reported are not as extensive as I first thought (hooray, cause the update is great otherwise), there is definitely something going on here with changing the state to hidden on drop.

Greg Hagar

After rebuilding the slides in question in a new project I think I've narrowed the problem down. It seems that changing the object state to "hidden" when that object is dropped on a target works UNLESS there's an associated "when object stops intersecting with" trigger to change the same  object's state when it stops intersecting with the drag target.  Remove that trigger and everything works fine.