Lightbox Is not working correctly

Apr 20, 2020

I am getting an error as I try to use the program created by Stephanie Harnett to add notes to a project and then print them to a PDF. Up to this point, I am not able to use the Global Notes in the Lightbox slide. In fact, if I try to use Lightbox at all it has a problem.

When I publish and run Stephanie’s project, I have a problem with the Global NotePad. I can type on it the first time it appears, but if I try again, I only see a blank white slide. When I click the X to close it I see three circles as if the program is looking for something.

When I create a lightbox slide without Stephanie’s coding, I get the same result. I click the button that triggers closing the lightbox. When I try to open the lightbox again, I get the same blank slide and the three circles when I try to close.

See video and storyline example attached.

15 Replies
Leslie McKerchie

Hello Jeffrey,

Thank you for the detailed explanation and video.

I see the same behavior when taking a look at your project file and when importing a couple of your slides into a new project.

What I cannot do, is replicate this issue. Here's my published sample.

  • Are you able to replicate the issue in my super simple sample project? 
  • Did you import your lightbox from Stephanie's sample or did you create yours from scratch?
Jeffrey Riley

Leslie, thanks for the reply. I have done this both ways. I have imported Stephanie's sample into an example of mine. The one I sent you I created from scratch with out using any of her code.

When I use the short one you made it works without the errors I reported. When I use Stephanie's it has the error. I can use her version from the post she made but not from my laptop.

I can clear the cache and see if that is part of the issue.

Lauren Connelly

Hi Jeffery!

I just tested your file on my end using Storyline 360 Update 39, and it worked as expected!

This was a bug that we saw in Update 37 (Build 3.37.21453.0) and just released the fix in Update 39 (Build 3.39.21985.0) this week. Can you update Storyline 360 in your desktop app and try to open the project again?

Here's what the project looks like in Storyline 360 Update 39 (Build 3.39.21985.0):

Jeffrey Riley

I had time today to test all of the features Stephanie included in her example. I used her downloaded files and published the file for Web to test.

I am attaching a video but I am now not able to drag the draggable note, I cannot use the Slide-in note at all, but the Global Note does work. At the end, I am not able to print the notes to PDF as the example demonstrates.

You may want to work with Stephanie on this.

Lauren Connelly

Hi Jeffrey!

It looks like the Hover state of the button to close the lightbox has the X on the right side of the slide. Luckily it's a quick fix where you'd need to edit the Hover state. Here's a tutorial on how to do that. 

Next, I see the scrolling panels are displayed showing the bottom portion first. Unfortunately, this is a bug in Storyline 360 Update 39 (Build 3.39.21985.0). Our Engineering team is on it so we'll let you know when we release the bug fix. I'm so sorry this is affecting your slides!

Lauren Connelly

Hi Jeffrey!

I'm so excited that I get to come back to this discussion with great news!

We just released Storyline 360 Update 40 (Build 3.40.22208.0) today which includes the fix for this bug! You will no longer see the scrolling panels start at the bottom. 

Now all you need to do is update Storyline 360 in the Articulate 360 desktop app. Also, head over here to see all the features and fixes included in this update!

This discussion is closed. You can start a new discussion or contact Articulate Support.