Make Chrome play video instead of downloading it

I have a SL 360 presentation with buttons to open videos in a new window.

The buttons work fine in Firefox, but in Chrome, the video downloads instead of playing in a new browser window.

Is there code you can put in the video html5 page that will make Chrome open the video instead of download it?

Thanks,

K Petersen

6 Replies
Kate Petersen

Hi,

I have added the videos with buttons, with the trigger "Jump to URL/file"...

This works fine for Firefox.

If possible, I would like to force Chrome to open the videos instead of just downloading them. Otherwise I'll have to specifically discourage using Chrome.

What would I gain by inserting the video as web objects?

Thanks for your help.

Kate

Alyssa Gomez

Hi Kate! It sounds like you have a URL to your video file, is that correct?

If so, try this:

  1. Go to the Insert tab on the ribbon and click Web Object. The Insert Web Object window will appear.
  2. Type the URL of the video in the Address field.
  3. Decide how you want the video to display. Choose either Display in slide or Display in a new browser window.
  4. Mark the box to Load web object automatically if you want your video to load without any interaction from learners. Uncheck the box if you want your video to load only when learners click it.
  5. Click OK when you're finished.

Let me know if that helps!

Anuj Joshi

I know the thread is quite old. However, the easiest way you can attain this is by doing the following. 

1. Create a slide and insert your video there. 

2. Create a custom resources tab on player and add a trigger. 

3. The trigger should open the slide with video ( Treat that slide as lightbox).

4. This will run the video instead of asking a user to download. 

I hope this helps. 

 

PS: This will work if you have a single video. In case you have more than one video. Create a Resource menu on Slidemaster and then add the list of videos in that menu. 

Similar to above stes, add videos in slides and name accordingly. 

The specific menu from Slide Master should be triggered to a slide marked as lightbox. 

 

Hope this works.