MP4 video playback on older ipads

Hi all,

I have a module that has an mp4 video on the slide. I have set this up to play automatically, via a trigger, or when clicked/tapped.

The module is delivered specifically for the ipad, so uses the HTML5 output, and runs in Safari. We are unable to use the Articulate mobile player app, so everything runs from their LMS via the browser on the users' ipads.

Testing on ipad air and the video works perfectly, on either automatic playback settings, or by triggers. When viewing on an older ipad (ipad 2) the videos do not play at all. The client has a team of users using older generation ipads and is getting rather frustrated as to why their content isnt playing correctly on their ipads.

I seem to have exhausted everything I could think of, has anyone out there got any tips or advice that may solve this? The module is rather large, 227 slides in total so was wondering if this may have anything to do with it considering the lower spec of older ipads compared to the newer generation?

thanks very much

19 Replies
Brett Rockwood

Hello Darren,

I have also had problems with videos loading and playing on an iPad 2. Some have played successfully, others just load the first frame but never play, and some don't load anything at all. My suspicion is related to network speed / 3G. The wifi network I have in the office isn't very good so that may be something to look at with your users. The other thing is the 3G data connections of iPad 2 vs. is much slower than the LTE of the later iPads. In my experience 3G video connections have been fraught with problems.

 

Darren Heath

Emily, Brett thank you for your replies. I'll expand on my initial comments for you.

content has been produced in storyline 1 and 2 with the same results 

iPad air on ios7 plays the videos ok, iPad 2 on iOS7 and ios8  do not play the videos. You see the first frame, and regardless of how you have the video setup to play, it just doesn't work

iPads are connected via our office wifi, which gives speeds of 50mbps+ and again the iPad air plays the content, iPad 2 doesn't.

video file name is simple, intro.mp4 and contains no unsupported characters.

ive tried various triggers, play when timeline starts, play when user clicks a button, play on variable change. All work on iPad air, nothing on iPad 2. 

We have to test to iPad 2 and ios7 as our client  has issues thousands of iPads to their staff and not everyone has a nice shiny iPad air to use and has yet to authorise the upgrade to ios8 (not that the iOS update fixes things)

Thanks for your replies. 

Darren Heath

I will sort something out when I am back in the office Emily for you tomorrow morning.

we are dictated by our clients' IT policy and LMS, for that reason we are unable to enforce the installation of the mobile player app, and their LMS only supports scorm 1.2 and not tin can.

regards

darren

Darren Heath

I haven't got the exact file size of the video here currently, but it isn't particularly large, it runs for about 1 minute and is an h.264 mp4 clip.

same content has been tested and confirmed as working on iPad air, when some of my iPad 3s come back in the office tomorrow I'll test on them too

Darren Heath

I haven't got the exact file size of the video here currently, but it isn't particularly large, it runs for about 1 minute and is an h.264 mp4 clip.

same content has been tested and confirmed as working on iPad air, when some of my iPad 3s come back in the office tomorrow I'll test on them too

Brett Rockwood

Hi Phil and Darren. I'm just doing some testing now with my iPad 2 in Mobile Safari and in the corporate browser Web@Work from MobileIron. In both cases I am unable to play videos, some of which I did in SL1 and others in SL2. The ones done in SL1 go the the launch page as expected but then get stuck on the first frame — the seek bar scrolls as if it were playing but there is no audio or video action. The ones done in SL2 go directly to the large, full-screen play button, then show the first frame and freeze in the same way. These are not large videos 640 x 360 pixels about 5 minutes and between 5-10 megabytes.

RAM would seem a likely culprit but I don't have another iPad to test it on.

 

Darren Heath

Morning all, some further updates to my testing.

The content doesn't play on ipad mini, which would give weight to the issue being RAM related. I have also tested on a 4th Gen iPad and it isn't working on that either and a 2nd gen ipad 2

The only device so far i have it working on is an ipad air. (5th gen ipad)

The video is an MP4 video and is approximately 3.5Mb

It runs for 61 seconds, at 25fps and is 244x380px

Emily, how do you want me to send you an example? Our content is quite confidential so wouldnt really want to post it as an attachment on here.

thanks very much

Phil Mayor

Probably not RAM as iPad 3, 4 and Air all have 1gb.  The Air 2 has 2gb, have you tried putting the video on web sever and trying to play it outside of Storyline?

You could even take the published one out of the published files and do a comparison

You can submit a case here

http://www.articulate.com/support/contact/submit.php

 

 

Bjarne O

Hi Darren,

I'm facing similar challenges, as I need to support scorm lms'es on older iPads. But even with the limitations of HTML5 and the low specs of iPad2, I'm able to produce a reasonably responsive experience using h.264 video in good resolution, on both iPad 2 and older android tablets.

If you feel like trying a demo, the final attachment in this thread:

https://community.articulate.com/discussions/articulate-storyline/interrupting-video-during-playback-to-show-webobject-or-restarting-slide-by-trigger

I updated iOS to 8.1.1, and on my iPad that did solve some issues... I'm always testing in both mobile safari and chrome, and I require it to work in both browsers.

Best regards,
Bjarne

Darren Heath

Thanks all for your replies.

Emily I am unable to upload the content due to confidentiality, sorry.

To update you all: we run our storyline content through an IOS app 'wrapper'. this is required due to clients' requirements for offline viewing, and also they want to report more stats than their LMS is capable of. It is pretty much our own bespoke version of the 'mobile player app'.

Anyway, generally we find that if it works in safari it will work through our app but in this case the videos dont. However, when we run the content via our app the videos playback perfectly.

It is a strange one for sure, and something that we will hopefully get to the bottom of but for the time being our content is working fine through through our app.

thanks again