Multiple Quiz bank results on single result slide

I have multiple 'draw from quiz bank' slides, for each draw slide I have a separate result slide and then I also have a final result slide which shows individual quiz bank results and aggregate score too.

Attached is a sample of what I am trying to do. Storyline is acting strange,

1) Sometime separate result slide loose the check mark that select individual quiz bank automatically. I have go back and check it.

2) Sometime the review quiz button does not work.

3)Sometime on final result slide I get individual score but the overall score percentage is zero or sometime individual scores percentages are  zero but get the overall score percentage.

 

I am using SL2. Any help is appreciated.

8 Replies
Emily Ruby

Hello Vikas,

Taking a look at the file, it seems the wrong references were being used in the final results slides to show the addition/subtraction results.

i moved everything into a new file and created new results slides. See if the attached file works for you. I did not come across any issues with the review quiz or the check boxes being unchecked.

vikas gaddu

Thanks for getting back to me. I have multiple question bank but in your update you had only one. I don't know if that makes a difference. Please see attached has 2 banks, one for addition and other for multiplication. The review button does not show review on my end.

The Review button gets fixed if I use "selected questions" on my final quiz result slide instead of using 'selected results slide'. But then this makes the overall percentage as zero.

The timer option is also not visible when using  'selected results slide' option, but I have to go back to 'selected questions' and enable it there. This was kind of confusing.

Emily Ruby

Hello Vikas,

The file I shared did have 2 banks in it. I copied your file into a new file and just created new results slides, to make sure there was no confusion on the Variables being referenced in each results. 

I imported your above file as well, and was able to see the results on the final slide, also the review and retry quiz buttons are working.

Omar Wilkinson

Hi,

We created a course  with multiple quizes and results slides with the one Result Slide to combine all results in one (same as the example Emily provided)  which is set to track completion when we Publish it for LMS.  The problem is that the LMS is not recording the course as completed for the user.  It recognizes the slide and the information but the user is not shown as "Completed" though they have gone through the entire course and passed all of the various quizes.

 

Can you advise would could be the cause? 

Ashley Terwilliger

Hi Omar, 

Do you see a score for the user as well in your LMS, and if so is it a passing score? It would be worth also testing your course in another environment such as SCORM Cloud which is an industry standard for LMS content and you could take a look at this article for a walk through of how to test the content. 

If you're able to replicate the same behavior there, we'll want to take a look at the file in question to see how it's behaving and do some additional testing among our team. Can you share a copy of that .story file at this link with our Support team?