Multiple response question bug

Hi guys,

Recently I've started having problems with multiple response questions. In my project I have a questions bank. I have 17 multiple choice questions which have been created and styled with no problems. The "fun" begins when I try to create multiple response questions.

I go to insert new slide, select multiple response question, which opens the question editor. I enter the questions and the answers, then upon pressing save and close, I'm greeted with the Storyline error report window. Close this, and any formatting has been remove, along with all but the first answer, and a check box for the second answer has been placed in the middle of the answer area. Any attempt to edit the answer check boxes on stage results in the error report window popping up again and the slide reset to the aforementioned state.

Has anyone else had this problem? I'm finding it incredibly frustrating, and when it first cropped up on Friday, it resulted in me losing a large amount of work.

With each day that passes I'm finding Storyline increasingly buggy and flakey and using it is becoming a real chore.

13 Replies
Christine Hendrickson

Hi Andrew,

I apologize for the frustration with this, hopefully we can get you up and running soon. First, are you working with a Storyline project locally? It sounds like the crash may be because Storyline's attempting to save content to an external source.

1.  Work on your local drive (your C: drive). Working on a network drive or a USB drive can cause erratic behavior, including file corruption, loss of audio, and other unexpected behavior. 

2. You should also make sure the directory path to your project files and your published output is less than 260 characters (for example C:\Articulate).

3.  Avoid using special characters, accents or symbols in your file names.

Additional information regarding "Naming Files, Paths, and Namespaces" in Windows operating systems can be found in the following Microsoft article.

If the problem persists, can you tell me if you experience this in a specific project? If you can, please try creating new, blank Storyline project and try to create a new multiple response question. Does the same thing happen?

Thanks!

Lalit Shakyaver

Hi Andrew,

I'm having exactly the same issue with Storyline crashing when trying to add a multiple response question as well.

Just for reference,  I am saving my project locally and the filename has no special characters.

I tried as you suggested Christine and started a new project and added a multiple response question with no problems whatsoever.

Just for additional info, I know the project I'm working on was originally created on the initial release of SL and I've since upgraded, but I'm wondering if that could be part of the issue?

I'm hoping that you can provide a solution as I need these questions on my project.

Thanks in advance!

Christine Hendrickson

Good morning Lalit and Sathya,

You both make a good point. Have either of you tried to import the original course, that was created in the older version into a new course? Can you tell me if the same thing happens after doing this? 

If it doesn't crash after inserting the question slides into another course, it may just be an issue with the original file. If it does still happen, it's still a possibility that it's a problem with the file, but we may need to take a look at the files to see if we can narrow down the cause. If it is something with the update, we certainly need to test this so we can keep this from happening in the future. If this still continues after importing the question slides into a new course, please submit the .STORY file to us in a support case

If you do open a case, please share the case number(s) with me, so I can follow the progress and share any additional suggestions or solutions to this thread.

Thanks!

Lalit Shakyaver

Hi Christine,

It definitely appears to be a file problem for me anyways, as I'm leveraging an English story file (which I created first) and updating it to French.  I was trying to add the multi response question in the French story file and that keeps crashing when I do so.  However, when I add the same question to the English file, there is no problem at all! Funny as it really is the same file, I just renamed it and am updating text to French.

I'll try to send you both story files shortly in a support case for your review and hopefully the issue can be looked at.

Christine Hendrickson

Hi Lalit,

I was checking on your case this morning and I see that Jayem was working with you on that case, but the last update was on the 19th. Did you see his last response? If not, please let me know and I can try to send the message again. If so, and you're still unable to work with that question, please respond to Jayem so he can continue working with you. 

Thanks again for sharing the case number, I'll be sure to check in and follow up with you here on the forums.

Stephanie Merkel

I am also having an issue with multiple response questions.  I can add them with no issue and in the Slide View they look fine .  However, when I preview the course, the question does not appear.  I am working on my c: drive, I've updated the software and I've saved the file with a new name and nothing is working.

Leslie McKerchie

Hi Stephanie,

Thanks for letting us know that you're running into an issue with your multiple response question and for sharing those helpful images.

I have not seen a similar issue previously, but I'd be happy to take a look.

With your permission, I'd like to take a look at your project file to investigate what's happening. You can share it publicly here, or send it to me privately by uploading it here. I'll delete it when I'm done troubleshooting.