my custom pause button functionality is broken

Feb 06, 2014

Through building in a custom navigation for several courses I have worked on, I discovered that if I use a custom made pause button that calls to a layer that will pause the base timeline as demonstrated here:

...the pause function on that layer will break if I leave the page paused when I navigate off the page before returning to it. The pause button will not pause the timeline upon my return, BUT  it will still show the working play button when selected - meaning that the pause layer is still showing properly when selected. SIDE NOTE: I include nothing but a play button on my pause layers, that takes the place of my pause button, and hides the layer when selected (In addition to this, I have no other layer properties selected on this layer.)

Because of this issue, I have been adding an additional trigger to each of  my custom back and next buttons that hides the pause layer before moving to the next (or previous) page, which fixes the issue as long as this trigger is fired before leaving the page. This worked perfectly fine for me until I tried to introduce a custom replay button to my course as well as leverage the built in menu tab in the Storyline player.

(to better clarify: my replay button is a custom button that just sends the user to a blank page that has nothing on it except for a trigger that returns the user to the previous page upon start of the timeline. The button is seated on the master slide so that it is present on every page.)

So my current issue now, is that my back and next buttons do not break my pause layers, but if I navigate off the page using my replay button or the menu while the page is paused, it is broken the same way upon my return. 

To better illustrate what I am talking about I have included a demo story file that showcases how the pause layers break (see attached).

I have also tried adding the pause layer function to the master slide to possibly fix this issue, but it occurs with that setup as well. At the same time, moving my replay button to each individual slide while adding in the hide pause layer trigger, would of course fix its involvement in this issue, -but that still leaves the built in menu as our problem starter.

Has anyone experienced this issue?

Or better yet, does anyone have a solid solution for resolving it?

Any insight or help would be greatly appreciated since I am working in a time-frame and fear that this may be a legitimate issue with storyline that needs to be reported. 

thank you in advance.

5 Replies
Michael Hinze

Have a look at the first two slide in this revised file. I added a Play state to the pause button on the base layer and have it toggle a True/False variable. This variable is used to show/hide the pause layer and change the states of the pause/play button. This setup seems to work, give it a try. Also, you might want to consider putting pause layer, play/pause button and the slide trigger on the master slide, rather than having to replicate them on every slide.

Ty Ehrnschwender

Thanks for the feedback Michael.

I typically place my pause layer on the master slide, but for this particular project, the visual approach that we are going with has made it easier for us to just place them on each page.

I do like how your approach keeps everything paused from page to page, instead of just being localized to one page (this is how I normally handle my custom transcripts), but unfortunately, it does not solve my issue. I am still able to break the timeline pause by using the menu or the replay button to navigate off of a page, while it is actively paused, before returning to it.

To further clarify, it is only slides that were left paused when navigated away from (without any hide triggers added to the navigation buttons) that break in this manner.

If you have any other ideas on how to fix this issue, or even work around it. I would love to hear them!

Ty Ehrnschwender

Another layer to this issue is that if I select the Hide other slide layers option on my pause layer properties, this issue goes away.

But then every time I pause the audio, any layers that are currently showing hide:/ 

In theory, I could always build the entire course using states instead of layers, but that seems like that would end up being a bit taxing and possibly even annoying.


Ty Ehrnschwender

this has been identified as a known issue by the support team.

the recommended workaround is to turn on the  Hide other slide layers under Visibility for your pause layer (in addition to the Pause timeline of base layer option). Then you just need to get creative with showing and hiding the content you would typically show using layers, so that pausing does not ruin the experience you are trying to achieve with showing such content. 

Hopefully this is fixed in an update soon.

This discussion is closed. You can start a new discussion or contact Articulate Support.