Not getting popup w/ option to Zip when publishing to LMS

I'm having an issue I've never encoutered before and am hoping someone can give me an idea what's going on. When I publish using the LMS option, it appears to publish and saves the output in the folder; however, the Publish Successful popup never appears with the option to zip the files.

I created the course from a template that I've used several times without issue. After I had the issue the first time, I started a new course and copied the scenes over; when I published it worked just fine. Now I just went to republish after making a few adjustments, and the popup no longer appears. (It does appear when I publish to Word, however.)

Anyone have an idea what might be causing this? Or is there a way I can zip the files manually since I don't get the option in the popup?

Any assistance would be much appreciated!

Thanks,
Tessa

11 Replies
Justin Grenier

Good Afternoon, Tessa.

The option always exists to zip manually via WinZip or 7zip, but ideally we should figure out what's going on with that project.

Did I understand you to say that this particular problem is confined to one specific .story file?  If so, can you please submit a Support Case and be sure to include a copy of the affected .story file?  Thanks!

Tessa Maki

Hi Justin,

Thanks for the response. Yes, the issue has only been in one course that I've worked on.

I think I just stumbled upon the issue, though. After reducing the course down to four slides to send with the support case, it was still doing the same thing - no Publish Successful popup. Then I decided to change the title of it, and when I tried publishing again it worked just fine. Apparently there's an issue if the title gets to long; and actually, I think it has something to do with the length of the full path after the course is saved and not just the title. The reason I say this is because when I published it with the longer title, but inadvertantly saved it to a folder with a shorter title it worked just fine. But when I publish the exact same course to the right folder with the longer name, then it doesn't give me the Publish Successful popup. I've tested it multiple times, and this is definitely the case.

So there you have it...I just needed to shorten the title of my course. If you'd like any more information (like length of path that resulted in the issue), just let me know.

Thanks,

Tessa

Justin Grenier

This is excellent information, Tessa.

Long folder path names are a known issue, and you should always make sure the directory path to your project files and your published output is less than 260 characters.

In addition, working on a network drive or a USB drive can cause erratic behavior, including file corruption, loss of audio, and other expected behavior.  So, if the cause of the long path name is a network share, you'll want to try to avoid that.

Please let us know if you need anything else.  Thanks!

lauren smirfitt

I am experiencing the same issue. I am publishing an Articulate Storyline file that I have previously published many times. After clicking "Publish," the publishing progress/status dialog appears and all 22 slides seem to load. Then the dialog closes and instead of the dialog with lms/zip options appearing, it reverts back to the Publish/Cancel dialog screen.

Tessa Maki

How strange, Lauren! Especially if it's worked before. Did you make any changes to the title or location where it was saved? This was the problem for me - between the title and the file location, the path name was too long. If it's not this, I'm afraid I have no other ideas. Hopefully Justin or someone else will have some insight. Good luck!

Ashley Terwilliger

Hi Lauren,

As Tessa mentioned you'll want to check into any changes to the file name or path, and as indicated here to have the file path well below the 260 character limit as publishing adds additional characters.  You'll also want to ensure that you're publishing to a local drive (typically you C: drive). If ever checking into those elements you're still experiencing some difficulty please let us know and we'll be happy to take a look at your file. 

Debi Levine

Thanks, Ashley. To try Wendy's repair suggestions I'll have to go through our software help desk, which can take days and days...

Any ideas for other ways to solve the issue?
Thanks
Debi

Debi Levine
GMP Compliance
Shire
400 Patriot Way
Lexington, MA 02421
USA
Office: +(1) 781-482-9068
Mobile/Cell: +(1) 617-800-7397
dlevine@shire.com
www.shire.com

******************************************************
Shire plc, the ultimate parent of the Shire Group of companies, is registered in Jersey No. 99854
Registered Office: 22 Grenville Street, St Helier, Jersey JE4 8PX
******************************************************

Please consider the environment before printing this e-mail

This email and any files transmitted with it are confidential and
may be legally privileged and are intended solely for the use of
the individual or entity to whom they are addressed. If you are
not the intended recipient please note that any disclosure,
distribution, or copying of this email is strictly prohibited and may
be unlawful. If received in error, please delete this email and any
attachments and confirm this to the sender.

Ashley Terwilliger

Hi Debi,

If you're publishing behavior is not working as expected, and you've already confirmed you're publishing to a local drive and following along with the other guidelines here - the repair will be the next step. 

Also, as an FYI - when you reply via email your signature is included in the reply so you can edit the post to remove that information.