POSSIBLE BUG - Play button now appearing in published courses

Hi, after updating my SL360 install today, all courses published are now displayed in browsers with a dirty big (badly designed!) play button at the very start of them.

This happens in Firefox, not in IE.... but it is not a browser issue.

I believe this is a bug introduced in the latest update.

To test this, I went back to a project I created two weeks ago in SL360 and tested its output via the exact same browsers on the exact same computers.

All worked perfectly, starting straight into the first slide once loaded with no play button in sight.

Whereas, all courses published with the udpated SL360 place this horrible PLAY button in front of it.

I have to remove this immediately as this is my livelihood and my clients will not accept their material now changing to this.

Please advise what I can do. Thanks.

24 Replies
Andrew Hanley

Done some more testing. It doesnt happen when I view the published files locally.

But it does happen when I put them on the web server.

Something in the new way Storyline is publishing the files is causing the server to force a PLAY button appear. Is Storyline telling the browser that we are mobile mode?!

Tried two different servers to double check.

All tests carried out on same computer, same browsers, etc.

Alyssa Gomez

Hi Janine,

Chrome changed the way they handle media autoplay in the latest update, so it sounds like you've run into that behavior. Using a blank slide at the beginning of the content is a good workaround, as Chrome is looking for a user initiation on the page to allow media items to play automatically.

Walt Hamilton

To piggyback on Alyssa's post, a blank slide will prevent the appearance of the play button, but the first media in the project will not play unless the user clicks first.

With a blank slide, your project will advance normally, but the first audio or video will not play (no matter where they are located in the project) until the user clicks somewhere.

Andrew Hanley

So maybe its a better solution to have that first slide say something like...

"Welcome to this eLearning course. Click continue to get started."

and a nciely designed continue button on screen.

I could see my clients and users not being as upset by that because at least we get to design the visuals.

Andrew Hanley

P.S. Its important to remember that different browsers and LMS's will exhibit different behaviour.

For example, none of this is a problem in IE.

In Firefox, the blank slide "workaround" works perfectly, and the audio and video do start playing without further user input.

It seems like the biggest offenders are Chrome and Safari.

Ted Nguyen

Alyssa, 

I understand what you're stating.  If the latest Chrome update is causing this issue.  Then why are my courses on our LMS published before the latest 360 update are working without the play button?  Right after I updated 360 and publish my courses is when I am getting the play button at the beginning. I am not leaning toward the latest Chrome 66 update as not the problem, but more towards 360 latest updates as a bug.
I tried Andrew's suggestion and it works, but it is not ideal. 

Tony Sundell

Hey. We are experiencing the same "feature" on our course development.  By removing all audio content from the first page we can get rid of the ugly and badly designed play button, but I feel like this strips away a creative freedom in content production:

What if we wish to play an audio at start of the content, but with a very low audio volume or gradually increase the volume? What if someone wants to support visually impaired students with audio-first solution from the get go?

Ted Nguyen

Tony, that's our situation.  I have audio that tells students what they need to do before they can continue with the course.  The idea of going back and adding an extra blank slide is not ideal even if it is for half a second.  It's the unnecessary work I have to do for lots of courses.

Alyssa Gomez

Hi there Ted,

We've seen that content published with Storyline 360 prior to 3.15.155581 will be affected by the new audio playback policies of Chrome 66 and later. 

You mentioned that your older courses play normally without the "Play" button on the first slide. I'm not sure why older courses would play normally, and newer ones would have the "Play" button, if all of the courses are hosted on the same domain.

I'd like to have our Support Engineers speak with you further on this. Can you help me with a few more details?

  • Were all courses published with Storyline 360, or were some published with Storyline 2?
  • Are all courses hosted on the same LMS domain? 
  • Can you share an example of a file that plays normally and an example of a file that displays a "Play" button by clicking this link? 

 

Alyssa Gomez

Hi James,

Google changed the way media is handled in Chrome 66, so audio in your Storyline HTML5 courses might not play in Chrome 66 and later. We added support for Chrome 66 in the April 26, 2018 update for Storyline 360. Install the latest update and republish your course to take advantage of the support we added.

You mentioned you're seeing a problem in Firefox, as well. A few other folks have also run into the "play" button in Firefox recently, and our team is looking into that behavior, since Firefox hasn't implemented the same autoplay policies yet. We'll keep you posted on that!

Ted Nguyen

Alyssa, the courses that work was a couple of days before the latest 360 update.  They are all build on a series with the same layout and format.  There's an audio file on the first slide to warn students what they need to do in order to get completion.  I don't use SL2.  All courses are hosted on the same LMS.  I can't share the link, unfortunately.

Ted Nguyen

Alyssa,

I painful as it is.  Our group has decided to revamp our courses.  This means removing all the audio file from our intro slide, so our students don't run into the large play button.  I will have to design it differently.   This keeps us in alignment with the new Chrome 66 implementation.

Michael Jones

I realize it's a long shot for a lot of organizations, but this article shows how to disable the autoplay policy in Chrome.

https://9to5google.com/2018/02/15/how-to-disable-autoplay-videos-chrome/

You'll want to change the autoplay-policy flag to "no user gesture required."

We instructed folks to adjust their settings in Safari when they implemented a similar feature a number of months ago. Hope that helps!

Crystal Horn

Hey everybody. I'm excited to let you know that we just released update 17 for Storyline 360! It includes new features and fixes - check them all out here.

One of the fixes addresses an issue where in HTML5, the course does not automatically play in Firefox when audio or video is added to the first slide.

Here’s how you can update Storyline 360 to take advantage of everything the latest release has to offer. Let me know how you make out!