Problem with Publishing

Jun 20, 2017

We have a serious problem with publishing some of our courses.  Initially we had 2 courses (let's call them A and B) in English and we developed them with a help from a certain company - we provided the content. So later on we translated the courses to Spanish and French and the content was after that updated. Now, I can publish both English A and B courses but the Spanish and French can't be published. All the courses have the same look and feel so i assume that English version was used to put together the Spanish and French version of both courses. 

Storyline starts publishing OK but I can see that it's consuming more and more RAM, almost 3GB; my PC has 16GB and I closed all the other programs.  When it cams near the end of publishing it stops. 

Few months ago I uploaded the files to Articulate and I was told that Master Slides are corrupt but I can see no evidence of that. Any ideas?

I'm attaching the error report created by Storyline (we're using the latest build of version 2), and the screen shot of the error.

Help anybody!

10 Replies
Leslie McKerchie

Hello Dejan,

Sorry to hear that you've run into an issue publishing. 

Thanks for letting us know that you worked with support on this issue previously (01077063).

Did you recreate the master slides and layouts as was suggested to you by Ryan and now you are having a new issue or is this the same issue that you worked with Ryan on?

Corruption isn't really something we can 'see' a lot of the time, but looks like Ryan confirmed based on the behavior he saw when working with and publishing your courses.

Jorge Cordoba

Thank you for your answers.

I tried importing entire course to a new file but it didn't work out.

Now I started importing module by module and I discovered that all is well until Module 2 slide 16. If I import slide 16 (which uses the same layout slide as previous 15 slides) I can't publish. Without slide 16 I can publish the course.

Now I'll try to recreate slide 16 and see if that resolves the issue. I can preview the slide 16 just fine and it looks OK. 

Any idea why one slide can prevent publishing? Any useful information from error file?

Jorge Cordoba

Now I really hit the wall and it's becoming beyond frustrating. I started importing slides to a new file and I test publishing all the time. So far I had to recreate a few slides, it was slow progress but steady. Now I reached a point in the middle of the 4th scene (out of 6 scenes) where I can publish a course until slide 16. If I add two more slides (empty ones, that use the same master slide for scene 4) I can't publish the course!

What could possibly be wrong with empty slide based on previously used layout? Isn't there anything in the error log I sent that can give you guys a hint what is preventing me from publishing the course?

Ashley Terwilliger-Pollard

Hi Dejan,

The original error report from Storyline crashing showed a lot of high memory usage and Ryan noted that something was off within the slide masters that could be contributing to the crashing and errors. 

Corruption of a slide master or an entire file is hard to pin down, and since this file came from another colleague it's even harder to know if they adhered to all the best practices outlined here. 

Have you tried rebuilding the master? Or adding in slides that don't reference that master?

Ren Gomez

Hi Navcon,

Thanks for reaching out! To answer your question:

We need to know how to publish the old version of a course into an updated version?

Simply upgrade Storyline 360 to the latest version, and open your .story file to re-publish your course!

Though I'm curious about what issue you're facing with the text "breaking." Can you share some more details, or even a screenshot of what you're experiencing so we may be able to help troubleshoot?

This discussion is closed. You can start a new discussion or contact Articulate Support.