Problems importing Powerpoint into Articulate Storyline

May 05, 2016

Exception during Import Powerpoint:

The given key was not present in the dictionary.


Can anyone help? Or have any idea what this could mean?

23 Replies
Crystal Horn

Hi Stephanie.  I'm sorry you're getting that error message!  I just wanted to confirm a couple of things:

Are both of your files (.story and .ppt) stored on your local hard drive?  Also, are you able to open the PowerPoint file independently?

If this error is happening across the board with any Storyline file attempting to import your PowerPoint content, you can run a repair for Storyline.

Ashley Kirstein

Thanks for posting, Stephanie.

I'm encountering the same issue with my import. I've saved the .pptx and my .story files to my local drive. I keep getting this error when importing slides into the .story file, even when attempting to import just a few slides at a time.

This is the only .story file I'm having this issue with, which makes me think perhaps it's corrupted (I hope not). Crystal, thanks for posting the repair--I'll try that next. Stephanie, were you able to resolve your error?


Jennifer Peters

I had the same problem with a particular PPT file. I unsuccessfully tried importing it into a new Storyline file, and then tried cutting/pasting all of the PPT slides into a new PPT file. If I only imported 2-4 slides at a time I didn't get the error message. Not the most elegant workaround (since it took all morning to import my file) but it worked!

Laura Middlesworth

Hi all- Thank you for this thread as I just encountered this error and was grateful to see it was not just me!  (And within an hour of successfully importing another PPT into SL360, so I was sure it wasn't an issue with either program.)

After much trial and error, I realized it was only select slides causing the import error (similar to what Jennifer shared), and those slides did use the same slide master in PPT.  I am not 100% certain what, exactly, on that slide master created issues, but I was able to successfully import all of the PPT slides into SL360 after assigning a new slide layout (from a different master) to those troublesome slides.  Maybe worth a try for those looking for other options.

Crystal Horn

Hi there, Mischelle. When working through a large project like that, it may help to import a range of slides to see if you can narrow down which slide is causing an issue.  Perhaps starting with a range of 10 at a time will help.  Feel free to share your .ppt here for some help!

Lauren Connelly

Hi Todd!

Thank you so much for sharing your project! It looks like you're publishing both HTML5 and Flash outputs. Are you using the HTML5?

I've uploaded your project to Amazon Web Services and only used the HTML5 output, presentation_html5.html. I'm not seeing the "specified key does not exist" error message. Here's the link I've used.

Let me know if you're still seeing the error message with the link I've shared. If not, make sure you're using the HTML5 output and not Flash.

Todd Ballenger

I tried both formats with and without and got it both ways.

I’ll try again.

Todd K. Ballenger
Director - Alumni and Career Networks
207 Graham Memorial | CB# 3510 | Chapel Hill, NC 27599-3510
desk: 919.843.4334 | mobile: 919.309.9078 | Zoom
email: | website:
Join the Go Anywhere Platform!


Leslie McKerchie

Thanks for the update, Todd.

I see that you're working with Jose on our support team as well, so please reply there if you experience any additional errors.

It looks like your email signature came through when you replied via email. You can remove that if needed by clicking ‘Edit’ beneath your response. Here’s a quick Peek video if you need help.

Alison Coops

I am encountering this error when trying to import a PPT of 46 slides into a new Storyline 3 file.  I previously imported a PPT file with the same template with 42 slides with no issue. It seems like many people are encountering this issue. Maybe someone there could figure out what the error means and therefore what is causing it?


Alison Coops

I imported the first 18 slides.  No problem.  The next 18 slides, no problem, the last 10 slides, no problem. So far everything looks perfectly fine after 2 or three tries getting the above error each time I tried to import the whole thing at once. Because I imported in 3 chunks  Because of a previous attempt and importing in 3 chunks I now have 5 sets of master slides.  Very annoying.

Becca Levan

Oh no, Alison, that does sound frustrating! I appreciate your efforts here and keeping us up to date on the outcome. From here, I'd like to invite one of our support engineers to help provide some insight into this.

I've opened a case on your behalf, so you should have received an email from me with a case number and a private upload link. If you're able to share your file, we'd be happy to investigate! As soon as we receive it, one of my teammates will reach out.