Problems with Shapes

Whenever I try to draw any shape from the shapes menu (such as a rectangle, oval, etc). I cannot click-drag to create the size of the shape I want.

I would assume I could do the following (as I do in PPT):

  1. Select the shape from the shapes menu.
  2. Click and drag on the stage to create an oval, rectangle or whatever.
  3. Resize the shape as necessary.

What I actually have to do is:

  1. Select the shape from the shapes menu.
  2. Single-click on the stage to create the basic shape (can't click-drag)
  3. Resize the shape.

Does anyone else have to do this? Is this normal?

16 Replies
Russ Lowder

I started having this same issue at least two version ago with Storyline 2. The repair install instructions don't seem to apply. When I attempt to run as administrator I only get the option to uninstall - no reinstall option. I'm on Windows 7. My files are all local (on my computers hard drive). This issue is mostly annoying but it would be nice to find a fix. I don't think a reinstall will help since this has been going on for at least the last two iterations of Storyline 2 - but I could be wrong. I'm on Update 7: 1509.1408. Any suggestions?

Walt Hamilton

You can correct this by going to Arrange/Align/Grid Settings and select both Snap objects to grid and Snap objects to other objects.

This is a workaround that usually works, but it is still a problem with the program.

Sometimes if you have shapes on the slide, you can deselect those snaps and it will work, but if you have a new project, and an empty slide with neither snap selected, you can always reproduce it.

Jim Rehmann

Well, I reinstalled (twice I believe) since I started experiencing the problem. It will work for a while, but then it goes back to the old behavior. Walt's thread is correct, the following will fix it, even though it's a work-around. Thanks Walt!

"You can correct this by going to Arrange/Align/Grid Settings and select both Snap objects to grid and Snap objects to other objects."

Ashley Terwilliger

Hi Jim,

Can you tell me the steps you go through to see the issue? I'm not seeing any particular oddness with working with shapes in Storyline but if it's something you can consistently reproduce I can share it with our QA team to investigate further. If you don't have a screen recording tool, you could use another instance of Storyline to record the behavior or Replay. 

Russ Lowder

Ashley, all I have to do is turn off the Snap Objects to Grid and Snap Objects to Other Objects and the issue comes back - turn the Snap... back on and the issue goes away. It's mostly annoying because I don't like to have Snap on all the time - but I also don't like the way the insert object works when Snap is off.

I have Replay and can record the issue but due to security issues I can only upload to an open case with support but not to the forums. Would that be helpful?

Walt Hamilton

I can verify that it works exactly that same way for me.

Russ Lowder

Ashley, all I have to do is turn off the Snap Objects to Grid and Snap Objects to Other Objects and the issue comes back - turn the Snap... back on and the issue goes away. It's mostly annoying because I don't like to have Snap on all the time - but I also don't like the way the insert object works when Snap is off.

 

Leslie McKerchie

Hi Russ! I am able to see a difference in adding a the first shape when I turn the settings off that you are mentioning, but have no issue afterwards on subsequent insertion of states. 

I would recommend that you share your screen recording so that we can fully understand and see if our team can re-create and understand what may be going on. 

You can submit that privately here.