Project won't save. System memory low.

I'm getting a system memory low error when I try to save. I am running Articulate within a virtual pc on a mac. I have given the VM 8 gigs of memory. That's a ton! The project is large (over 600 slides) but not really a big file size (65 MB). Any ideas out there? Articulate is already running painfully slow (I'm guessing because of the size of the project), but now I can't save my work. For a while I could "save as", but now I can't do that...

8 Replies
Alexandros Anoyatis

Hi Matt,

8 GB or not, you can't utilize more than 4GB of Memory when running 32-bit Windows Processes (whether your Guest OS is 64-bit or not). The default is even less than that (actually 2GB) unless the application is "large address space aware". I'm not sure if SL is or isn't, that's a question for the support team to answer.

My only advice is to have Task Manager open at all times when dealing with large Storyline projects, so you know how large the footprint is at any given time.

Hope this helps,
Alex

Mike Enders

Matt,

I'm not sure what might be causing the issue. I recall that I had a similar situation about a year ago (it was something goofy with my machine that occurred after a Windows update). As a potential save (before you close out your course and lose your changes). Try opening up a 2nd instance of Storyline, and then copying and pasting your slides from the the original deck over into the new deck. Then try saving the new file.

Mike

Matt Nagy

Thanks to both of you... Mike, I have tried numerous times to do just that... copy to a new instance, and cannot make it happen. Nothing will copy. Have you actually been able to make that happen? I have 5 scenes within the big project and I've tried to copy a scene, and tried to copy all the slides within a scene, but neither will paste. Any suggestions?

Matt Nagy

Cheryl Parmelee said:

I had that happen this week, Try a file save as instead of just save. Mine saved, I gave it a different name. Also try saving to a differnt folder. It might work out.


Thanks Cheryl. That actually did work for a while, but then even that ran into the error. I also tried saving to a couple different locations thinking that the location/file was corrupt, but that didn't work either. I'm getting nervous as I have spent a huge amount of time on this project and there is still a ton of work to be done on it.

Matt Nagy

I'm in the process of upgrading my VM to a 64 bit Windows install. I believe that Alex nailed it right off the bat, and I'm going to try that fix. I think that also might be why I can't paste into another instance... memory. I was running a 32 bit Windows 7 VM and it was only giving me 2.75 gigs of RAM. I'll post if this works.... I have high hopes! Thanks to everyone.

Matt Nagy

Problem solved. Luckily for me, I had access to a 64 bit version of Windows 7. I made a new VM (Virtual Machine) that uses Windows 7, 64 bit, loaded Articulate, copied over my files, and I haven't had a problem since. For any future users of the forum, I am using Articulate through Parallels on a Macintosh. With the 64 bit version, I now have access to as much RAM as I want.

Side note: Articulate works really slowly when your projects get large. Duplicating slides and saving the project give me time to go do something else. Ugh.