Published Storyline Course Refuses to Play

Please help!

I've spent a lot of time creating an e-learning course for work using storyline. I've published it in every format (although I only need the basic html version). When I click on the story.html version or the flash version, it plays fine on my computer. But when my co-workers try to play it on theirs (as they do not have storyline or any other design files on their computer), they get a blank screen. Nothing plays.

One of my co-workers tried to see if their flash player was up to date but it said it was when they went to the flash website. Still no go.

I had them to try different browsers but the same thing happens. Nothing.

I tried uploading it to my website by submitting the flash version. All I get is this

That's it.

I've tried my sharepoint site. Same thing. Nothing.

I'm trying not to panic, but no one knows why it won't play. It's only 9 slides. I don't know what to do. Please tell me that someone has an idea of what's going wrong!

Thank you,

Rachel

6 Replies
Ashley Terwilliger

Hi Rachel,

When you're uploading the course, are you uploading the entire published output folder? That error message looks like you're only accessing the one file.  Additionally, if anyone is viewing the published file (they'll want to use the story.html link) on their local drive they may be encountering some security restrictions as described here. 

If you don't have access to a web server or would like some other testing options, here are a few free options to consider:

  • Tempshare: This is a free service provided by Articulate for testing Storyline content. Note: Uploaded files will be deleted after 10 days.
  • Amazon S3: Amazon S3 offers free hosting with generous usage limits. If you go over your limit, you'll be charged a graduated fee.
  • Dropbox: Place your published output in the Public folder in your Dropbox account to share it with others.
  • Google Drive: Change the story.html file to index.html, and set the sharing permissions to PublicHere's how.
Rachel Anderson

Hi Ashley,

That's the exact article that I went to myself but I still can't quite seem to figure this out.

I understand but something has to be wrong. I'll explain why...(this may be lengthy)

I did some courses for my old job and everything worked perfectly. Yes you may get the security restriction but all you have to do is tell the browser when it does the little pop up about it is that it's okay and everything works just fine.

Now at this newer job when I finished an elearning course and try to share it, none of my coworkers can access it. They don't even receive the popup security message BUT when it's on my computer and my boss computer, it does the security message and works fine (we both have storyline on our computers and we used the story.html file that we have told everyone else to use). I would think that no matter what since all the computers have the output file to its entirety then that html file should play but it doesn't. We all are using the same wireless network with the same settings but that html file refuses to play unless it's on a computer that has storyline. Shouldn't that not matter?

Tempshare seems to work great as I was able to finally get my coworkers to see the course...it's just that I need a permanant place to upload the link.

Actually I'm kind of confused about using dropbox and google drive, is this just a suggestion for people to download the zip file? At the moment, I'm more focused on why the module won't work on other computers even if they have the entire output folder. I'm not sure how to upload the entire folder online to get it to work through a link that way. We want at least have a shareable link for people to view the course easily without having to download the whole thing onto their computer and of course that's a step ahead of just tyring to get it a play even if all the output files are on the computer.

Do you have any advice on what I should do at this point or some instructions in how it works to get public files to actually play with dropbox and google drive? I tried uploading the entire output file to public folders but when I click the link it either shows a blank screen like always (html link) or the spinning wheel screenshot that I showed you above (flash link).

Ashley Terwilliger

Hi Rachel,

The security restrictions for playing files locally are a common issue, but it does seem odd that you and your boss can play it and you're the only ones with Storyline. When you share the output folders, how is it shared with all the other users? If you only send a link to a story.html file from within the output folder and they don't have the entire output folder - the course won't play. If they have the entire output folder did you check that you're all testing it in the same browser with the same Flash version? A great site to help you gather these details from your coworkers is supportdetails.com.   Did you try publishing for CD? 

Mike Taylor has some great directions here on how to share your published files with Google Drive. 

David Anderson has a tutorial below on how to use Dropbox with your published content:

Rachel Anderson

Ah ha!!!
I've figured it out.


While I was trying out Google Drive to host it (which works great by the way, very easy to do but with dropbox I accidentally deleted the Public folder a long time ago and didn't know how in the settings to get it back), I noticed that in the instructions it says to rename the story.html file to index.html then so on and so forth.

Sooo out of curiosity, I changed story.html to index.html, zipped the folder, and instead of uploading it, I sent it to my co-worker. When she opened it, it immediately came up without any trouble at all! How about that!

I don't remember ever having to do that before whenever I shared the course. I've always clicked the zip folder option in Storyline and sent the zipped course to others and they were able to open story.html without any issues at all so this is the first time that it has ever required an extra step such as changing the name of the file despite having the same browser, wireless network with security settings, and updated version of Flash.

Thank you Ashley for helping me figure this mystery out! I do appreciate all of your suggestions!