Publishing issues

Hi, I'm having a problem with publishing, I've been using Storyline for a few months and everything has been working fine.  But not all of sudden when I try to publish, in only publishes the mobile, story_content and Temp folders along with a meta.xml file.  The publish screen goes through the process of publishing each slide and then goes back to the publish screen, it never goes all the way through.  Can anyone help? I already tried re-installing Storyline and I'm able to publish the same file using a different machine. I'm running Windows XP Professional through Parallels on a Mac.  Thanks

8 Replies
Christine Hendrickson

Hi Victor,

First thing I would want to check is the location of the project files. Are they all located on your local hard drive? If you're working off of a USB drive, network drive, or any other external source, you may run into some unexpected problems. If you haven't already, please try moving the files to your hard drive and see if they'll publish.

Here's some additional information:

If you are experiencing unexpected issues using Articulate software, here are some tips for managing your files which can help prevent issues.

1.  Work on your local drive (your C: drive). Working on a network drive or a USB drive can cause erratic behavior, including file corruption, loss of audio, and other unexpected behavior. 

2. You should also make sure the directory path to your project files and your published output is less than 260 characters (for example C:\Articulate).

3.  Avoid using special characters, accents or symbols in your file names.

Additional information regarding "Naming Files, Paths, and Namespaces" in Windows operating systems can be found in the following Microsoft article.

_________________________________________________________

If you've checked and confirmed that the files are local, are you able to share your .story file here so I take a look and see if I experience the same thing?

Thanks!

Victor Peraza

Hi Christine,

Thanks for responding so fast.  I am publishing to my local drive and there's nothing out of the ordinary with the name of the file or directory.  The file works fine when I publish from a different computer, and Storyline had been working fine on my computer until now.  Attached is the file, luckily it's still in the draft process.

Christine Hendrickson

Hi again Victor,

I was able to successfully publish the course for LMS. Is this how you were publishing it, as well? 

Can you try something for me, please? Download the attached file and save it to your Windows desktop on the Parallels. It's the same file, simply renamed. Try publishing with that file and see if it publishes correctly. 

Thanks again!

Victor Peraza

Christine,

It still did not work, originally I was trying to publish for Web, but even publishing for LMS does not work.  It does the same thing, stars the process, does the slide count with the progress bar and then goes back to the publish screen.  I never get the publish confirmation screen.

Christine Hendrickson

Hi Victor,

Sorry to hear that, I had hoped maybe creating a new instance of the file would fix the issue. I'm assuming this will happen if you create a blank, new course as well, then. Have you already tried doing that, as well?

If possible, please try to follow the troubleshooting steps outlined in this knowledge base article. Keep in mind that all of the steps listed for XP will need to be completed through Parallels, though, no changes need to be made on the Mac side.

If the issue continues after following those steps, please go ahead and submit a support case with us so we can take a closer look. You'll be able to share a link in that form for this forum thread, so our technical support team will see the steps you've already taken to troubleshoot this. Also, please share the case details with me (you're welcome to do so here, or in a private message) so that I can follow the progress of the case and update this thread with any additional suggestions or solutions.

Hopefully we'll be able to get this fixed for you soon, Victor.

Thanks again,

Christine

Victor Peraza

Hi Christine,

I unistalled Storyline and ran the slCleanup.bat file after.  I went ahead and re-installed Storyline and tried to publish my file again.  It worked! I guess uninstalling using the Control Panel still left some remnants on my computer, but after running the slCleanup file everything seems to be working fine.  Thank you very much for your help, I really appreciate it.

Victor