Publishing to Word -- gives 'read-only' error

When I attempt to Publish to Word from Storyline (so I can have reviewers and editors go through my content) I get this error:

I've reviewed or tried all the suggestions in the forum related to this topic but to no avail. Restarting my computer didn't change anything. 

I noticed that a Word dialog box appears every time I try this: 

I've tried with Word running when I publish, and with it closed. Same result each time.

I've selected Yes on this dialog and selected the .doc and .docx file types that Word should open. But the same error comes up anyway the next time I try to Publish to Word from Storyline.

3 Replies
Peter Anderson

Hi David, 

Really sorry for the trouble you're experiencing. Can you please be sure you're following some basic rules to prevent strange behavior:

  • Work on your local drive (your C: drive). Working on a network drive or a USB drive can cause erratic behavior, including file corruption, loss of audio, and other unexpected behavior. 
  • You should also make sure the directory path to your project files and your published output is less than 260 characters (for example C:\Articulate).
  • Avoid using special characters, accents or symbols in your file names.

If the issue still pops up, a simple repair may fix the problem. If not, please feel free to submit a ticket to our support team for additional help.

Thanks, David!

David Coughanour

Peter,

Thanks for providing the information I needed. Using the shorter path was indeed what I needed to do to resolve the problem.

Now let me vent a little....

It would have saved me hours of frustration if this document http://community.articulate.com/tutorials/products/publishing-a-project-for-word.aspx had been updated to include the fact that long pathnames can cause erratic behavior.  

Let me also give some feedback on behavior that I observed... trying to be thorough and systematic... I tried again to publish to Word using the same directory I was using yesterday and now it works fine (my machine has NOT been rebooted in the meantime and I did nothing to my repair Storyline installation and nothing to change the files themselves).

Also, the directory path I was trying to publish to yesterday was less than 100 characters all along so I wasn't bumping against the 260 character limitation anyway. 

Using a shorter directory path also resolved my issue with Publishing to the Web that I was encountering yesterday, but again the path I was using was never close to the 260 character limit. But the path that worked was less than 25 characters. (If you look at my post from last night you'll see that using very short paths does seem to help, but the behavior is not consistent or 100% replicable.) 

Peter Anderson

Hey David, 

I'm glad to hear that you've been able to get the project published; I'm just really sorry for all the frustration leading up to it. 

And thanks for including your troubleshooting notes - I'll look into why that may be happening. 

In the meantime, if you run into any other strange behavior or general questions, please don't hesitate to give us a shout. 

Thanks, David!