Quiz review - Next and Prev buttons not displaying

Hi everyone,

I have turned the Next and Previous buttons off in the slide navigation controls. When the quiz is completed and the user clicks the "review quiz" button, the feedback is displayed but there is no 'back' or 'next' button for the user to be able to move through and review their answers.

This has never been an issue for me in the past, but for some reason these buttons wont display this time. I thought this was a default feature for review slides? 

Thank you.

14 Replies
Stephanie EV

Thanks Wendy,

I thought it was a default behaviour but wasn't certain. I had a custom submit button, so I decided to make it easier for myself by removing this and enabling the system submit button   (this resulted in a return of the back and next quiz review buttons). 
Shame I couldn't keep the custom submit button, but I guess the SL quiz review wont work unless one of the buttons in the nav are enabled.

Thanks again.

Wendy Farmer

Hi Stephabie

 you could still use your custom submit button- just create a T/F variable called revQuiz that is default false. On the result slide review button set a trigger to adjust the variable to true when user clikxkw the review button (order above the jump to slide/review results) trigger

On the on the master layout the quiz questions in the slide properties tick both buttons.

Set a trigger to change state of next button to normal when timeline starts on condition  ‘revQuiz’ = true. Same for the prev button.

Set aanother trigger to change state of next button to hidden when timeline starts on condition ‘revQuiz’ is not equal to True. Same for the prev button.

that should work - shout out if you need help with it

Cynthia Kuil

Hello all,

I was very happy with this comment, but I have a related problem.  I arranged it al like above and it works, but.... not with a dynamic test with 3 attempts. The firts attemp works correct. But if you retry the test, the button submit doesn't show and the forward/previous button shows constantly.

Someone a solution?

Greetings Cynthia

Cynthia Kuil

Hey Leslie,

Thnx voor you reply. I'm comming here often, but not frequent with questions because a lot is already worked out :). Mondaymorning after a good weekend I got the Eureka moment... I have placed the next and previous buttons also on the basepages (the pages who has also feedback pages) with the same trickers as above.

The only thing is that when the student does the first attempt, and after he has seen the review a new test starts, not the submit button got, but the previous and next. The test acts normal and generates stil all information. So it works... Not quit as I wanted... but still....

So .... here is the file, hope you can see what I meen and you have a better solution :).


Greetz Cynthia

(excuse me for my english.... it's not my native language)

Ashley Terwilliger

Hi Cynthia,

Thanks for sharing your file. I took a look, and everything seems to be working as I'd expect in that once a user reaches the results slide they have the option to retake the quiz, which will reset everything and they'll see the submit button on all questions slides. 

They also have the option to review it, where the submit button is hidden and they'll see Correct/Incorrect feedback and can continue to navigate through all the questions using the next/previous button.

If you could share what else you'd like to have set up - I can try to point you in the right direction! 

Cynthia Kuil

Hi Ashley,

So far it works correct, but if you want to retry the quiz after you reviewd it, you don't get a submit button anymore. you only see the next and previous button (they work than as a submit button.... i don't understand why that suddenly changed). Maybe you see what is wrong in the trickers.

Greetz

Alyssa Gomez

Hi Cynthia!

When the user clicks the Review Quiz button, they are going back to review the answers they already submitted. They are not attempting the quiz again.

The Submit button is replaced by Previous and Next buttons so the learner can navigate through the questions to review their answers.

If this isn't what you'd like to happen when the learner clicks the Review Quiz button, can you tell us more about how you would like it to work?

Mysag

Hello People, 

I am facing same issue, i could not see next/prev button on review slides. I am using default player. I can not use custom button.

The SL quiz review is not working unless one of the buttons in the nav are enabled. When i enabled seekbar, then i can see next/prev button, but if unchecked then can't. 

Please provide solution if anyone solved this already. Thanks

 

Leslie McKerchie

Thanks for confirming Sagar.

I've not seen an issue when the built-in Submit button is being used, but we have seen it cause an issue with a custom submit button.

The workaround for the latter issue is to be sure that the volume button is enabled in the player.

Since you are experiencing something a bit different, would you be able to share your .story file so that we could take a look?

Also, it looks like you mentioned you are using update 3 and we are now on Update 18 of Storyline 360 and we do encourage you to utilize the latest :)