Red lines under misspelled word in browser

Hi All,

I have installed Storyline updates one week back, after that I can see wavy red lines under misspelled words in browser. We used to get spellcheck error lines under the wrong word while typing on slide, but in my case these red lines are showing up in preview mode after entering text in textentry box and comparing that answer in next layer. I never faced this issue before and can you pleas help me to fix this?

Thank in advance.

Veena.

20 Replies
Katie Riggio

Sorry you're seeing those lines above the text, Veena!

My initial hunch is that there could be a transparent text box somewhere on the slide. I see that my teammate, Renato, received your file and is carefully troubleshooting the setup.

You're in great hands, and we'll track down the culprit together!

Ashley Terwilliger-Pollard

Hi Henry,

I checked on Veena's case and saw that my colleague Renato also replicated it, and is reporting it to our team as a bug. We'll continue to investigate and keep you posted in this discussion as our team determines next steps.

Glad you were able to roll back to an earlier update in the meantime!

Katie Riggio

Hi Brett,

Thanks for checking in. I'm sorry that you ran into the issue where a red line for a spelling error appears on a slide layer.

It is currently in the early stages of review based on our How We Tackle Bugs article. To help you plan, it's unlikely to be fixed in the next couple of updates.

For now, we recommend creating a separate slide for the layer, if possible.

Let us know if you need a hand! I'll advocate on your behalf, and jump back in with any progress! 

Brett Hansen

Thank you Katie ...

I have been using Storyline for a few years now and this is the best response I have ever gotten in response to "bugs"; this allows us to plan and alter course. Thank you for the recommended workaround, a separate slide (or lightbox) will not work for me as we want the leaner to see what is on the screen and be able to take notes; the little note we created with some transparency was what the customer wanted … but thanks!

Tyler Sloan

I found a working solution in another thread posted by Matthew Bibby:

Try adding this JavaScript to your Master Slide and set it to run when the timeline starts.

if (!window.disabledSpellcheck) {
document.querySelector("input").setAttribute("spellcheck", "false");
document.querySelector("textarea").setAttribute("spellcheck", "false");
window.disabledSpellcheck = true;
}

Leslie Peters

I am really struggling with the red squiggles. I have determined they are random. Sometimes there is one, sometimes three. Sometimes they are in preview, sometimes not. In my LMS when I restart the module they sometimes disappear. This isn't acceptable. I have a project where we cannot remove the layer and turn it into a separate slide. What can I do? I remember seeing in a post from awhile ago spelling settings that suggested turn off spell check. I've tried different options there as well, to no avail.

Katie Riggio

So sorry that you ran into the red lines, Leslie.

You're in the right place for any new developments on this bug. For now, we know of these workarounds:

  1. Remove the layer and then create a separate slide.
  2. If #1 doesn't work for the design, add this JavaScript to the master slide and set it to launch when the timeline starts. Thanks for this find, Tyler!

    if (!window.disabledSpellcheck) {
    document.querySelector("input").setAttribute("spellcheck", "false");
    document.querySelector("textarea").setAttribute("spellcheck", "false");
    window.disabledSpellcheck = true;
    }

Even if you can't share your file, our Support team is happy to extend a hand if those ideas don't help!

Shay O'Donnell

Hi there,

Another +1 for this fix! Redesigning our content across slides rather than layers isn't an option for me in a current project, and I seem to be having trouble getting the Javascript to work.

It does seem to work, but for only one text entry field in the project (seemingly the 'first' box in the slide sequence), the rest of the text entry fields are still highlighting the spelling mistakes. Going to keep trying  with the Javascript, though, because it seems to have worked for others! 🤞🏼 

Lyndal Stewart

I agree, this is still an issue, I had someone look at this issue that is a developer and they said the issue is that the Javascript that is supplied to go int the master slide is not even firing.  I have spend days testing for this issue and putting in lots of work around and I cant go live until this issue is resolved.  In the testing that I have done I have also noticed that it works fine in Edge browser and I have no red squiggly lines (I have left the Javascript in anyway as above).  When I use exactly the same output file in Chrome, I get the red squiggly lines again.  I am on the latest version of Storyline 360 - 3.43.22859.0.  Weird thing was that I could swear this was working a month or so back in chrome.  This really does appear to be a Storyline issue due to the fact it works fine in Edge and IE and not in Chrome or Firefox.  Looks like the issue is a compatibility issue between Storyline and Chrome/ Firefox.  I am on this version of Chrome Version 84.0.4147.135 (Official Build) (64-bit) and this version of Edge Microsoft Edge 44.18362.449.0.  I have also tested on Internet Explorer version 11.1016.18362.0 and it works perfectly.  So I downloaded Firefox v 80.0 (64-bit)and tested on that and that also does not work.  I have also tried changing the spelling to US Dictionary from UK with no difference.  I agree with Shay, I am in the same position with layers, I cannot change the design of what I have, but would be super keen to end this frustrating issue and people keep pointing to the Javascript to turn off the spell checker but this is not working for all people, especially those with multiple layers...look forward to a fix for this one.

Katrina Fogelson

I am also having this issue as a result of having a freeform text entry box on the main layer, and on the 'response' (thank you for your feedback layer) the red squiggles are evident if there were any misspelled words in the text entry. Because of this, it isn't easy to have the layer become its own slide. 

I hope that Articulate will bump this issue up, as it deals with the learner's entry, and having the correct response for them (without interference of ghost squiggles, which can be off-putting).

Leslie McKerchie

Hi everyone,

Great news!  We just released another update for Articulate 360 and included a few important fixes that you'll see in the release notes here.  

The item you'll be interested in is:
Fixed: Scroll bars and red spell-check lines on one layer were visible on other layers when they should've been hidden.

Just launch the Articulate 360 desktop app on your computer and click the Update button for Storyline 360. Details here.

Please let us know if you have any questions, either here or by reaching out to our Support Engineers directly.