Reset Answers on Quiz Questions - Not Resetting

 I have a course set up that is modular based, at the end of each module is a results slide, at the very end of the course there is a main results slide that calculates from all of the other results slides for each module. If I am on a module (e.g. module 2) and I select answers that are incorrect, I have the results slide at the end the module set to restart them at the beginning of that module and they must complete it and answer each question correctly in order to advance to the next module. I have each slide set to "reset to initial state", and a trigger on the Retake Button that is supposed to reset. However it is not clearing the answers I set previously so I am unable to answer them again, even after changing the number of attempts allowed. Please help. Thanks!

5 Replies
Ashley Terwilliger-Pollard

Hi Stephanie,

Without seeing your .story file, my first thought is to check the trigger order associated with you "retry" button and ensure it's resetting the results for that results slide before jumping to slide X to restart that section of the course. Trigger order for these types of interactions is crucial and you can read a bit more about it here. If that's not what you're experiencing, can you please also share a copy of your .story file here so that we can take a look at the behavior. 

Bailey Knapton

Hi I am having the same issue with the questions not resetting. I have the triggers set in the correct order and when I test in SCORM cloud and I go back through to retry the questions the previous and next buttons are there and I can select anything. It works correctly when I test it in storyline, but not in the LMS

Leslie McKerchie

Hi Bailey,

Thanks for reaching out and letting us know that you've run into a similar issue.

You mentioned that it's working as expected within Storyline, but not within your LMS. 

I'm not clear if it's working as expected in SCORM Cloud or not based on your description:

when I test in SCORM cloud and I go back through to retry the questions the previous and next buttons are there and I can select anything

I assume since you are seeing the previous and next buttons, that the course is in review mode and it's not working as you intend.

With your permission, I'd like to take a look at your project file to investigate what's happening. You can share it publicly here, or send it to me privately by uploading it here. I'll delete it when I'm done troubleshooting.