Reset to initial state not working on an activity not being tracked

Oct 26, 2018

Morning, I have one more issue with my e-learning.  I have an activity (slide 2), I set it to "Reset to initial state" when revisiting.

but when I go to the next slide and press the previous button, the activity slide still shows what I typed in the text entry box.

I am thinking i need some type of trigger to clear the text entry box but can't figure it out.  And really thought resetting should have worked.

I have attached just the slide before and after the one I am having an issue with.  You can type anything in the text entry box the answer will come up when submit is pressed. 

This is not being tracked with a results slide, this is just a random activity they can try throughout the course.

Thanks Teresa

18 Replies
Teresa Vanderpost

Michael, you are fantastic!  The speed of your responses, is truly saving my butt as I am on a tight timeline. I was just going through the final run through when I noticed this.  I knew I had to do some type of trigger where there was no value but just couldn't figure it out.

Can you explain to me though why Reset to initial state for slide properties wouldn't have been enough.  I would think that was stating return it to original (meaning field blank) when you come back.  But I must not be processing it correctly.

You have been like my knight in shining armour the last few days.  Please know how truly appreciative I am!


silvia neal

I know this is an old post but hopefully someone can help me with the problem described in this post. I have added the trigger that Michael suggested but the text extry is not cleared when revisiting the slide. I'm attaching the slide for your reference. Thank you!

Phil Mayor

Look at the example I sent on the second slide. I am resetting the variable before the previous trigger.

I checked your slide trigger which is correct and should work and then I gave the variable initial value and found it reset. The only issue here is the slide is a question slide and some oddity is happening when you go back the slide is submitting before the reset trigger so it jumps forward again (which is why you thought it wasn't working). If you reset the value on previous it stops this happening.

silvia neal

I'm trying to make this work in another scene but it's not. Could you confirm what trigger I need to add and to which slide? When I test your file, clicking Previous on the first slide resets the text box on the first slide just fine. However, it doesn't work when you click Previous on the second slide (i.e. nothing happens). I've tried changing TextBox25 to TextBox24 (just in case) but that didn't work either. I am at a loss here. Should I open a case?

Katie Riggio

Hello Silvia,

Thanks for sharing the affected slides, and shout out to Phil for stepping in!

Like your experience with the latest file, the text box on the first slide resets when I click the Previous icon but doesn't reset on the following slides:

I believe this is connected to an open bug in Storyline 360 where text-entry fields integrated with question slides carry over pre-loaded text options on the following slide.

From here, I'd like to get a second opinion from our talented Support team to gain more insight. A case with all the relevant info provided here should be in your inbox.

See you there!

Lauren Connelly

Hello everyone!

I wanted to share that we are no longer seeing this bug, Jumping back to a Freeform text entry slide with When Revisiting set to "Reset to initial state" will bounce you back to your starting slide., in our latest version of Storyline 360.

I'd recommend using Storyline 360 (Build 3.61.27106.0) or later.

You can reach out to our Support Team in this discussion or privately in a support case.