Restore on Mouse Leave Error - Audio files

My base layer has an audio file. I also have three icons, which when hovered over, have their own audio files. I made a trigger so that when you hover over an icon, it pauses the base layer audio. Even though the "restore on mouse leave" is selected, when your mouse leaves the icon, the base layer audio does not continue. See attachment.

2 Replies
Jerry Beaucaire

I think you may have discovered a "design" decision in SL that works against your end goal.   You may want to send that to support@articulate.com in regards to a possible bug. (audio in a state interrupts regular audio and it does not resume)

In the meantime, you can get the effect you want by simply using layers instead.  

  1. Pull the audio out of the first icon and drop it onto a layer called 1.
  2. Change the trigger to show layer when mouse hovers over.
  3. Be sure to set the layer settings to PAUSE BASE LAYER.

__________________

I would be remiss if I didn't suggest you reconsider the idea of separate audio tracks interrupting each other.   My personal opinion is that it's a little jarring, you know?   

This is 100% personal preference, but my recommendation is to animate in some things onscreen during the long initial audio.  Then as the audio completes and you mention the "hover over each number", animate those numbers in at that point.  I'm suggesting ensuring the user waits until the initial audio is complete before initiating the questions and audio.   

I apologize if that's unwelcome additional advice.  ;)

Lauren Connelly

Hi Peyton!

Wow, this an impressive build!

I've recorded a quick screen recording to explain the changed I would recommend making. These changes would ensure the base layer audio plays first and then the audio associated with each oval would follow.

I've also attached the updated course.

Please let me know if I can answer any questions!