Screen Recordings Won't Play in LMS

Greetings, All

I am in a jam and need quick help. I have a course that contains a screen recording (video on a single slide). The recording plays fine in preview mode. I published the course to the Web and it played fine in my browser, IE8, from the local drive on my computer. I published the course to LMS and uploaded it to our LMS (LearnShare). The course plays but when it comes to the slide containing the screen recording, it shows a blank slide. The seek bar shows progression at a pace that indicates the proper duration for the recording, but there is no audio or video in the slide. The Next button will take you to the next slide and everything else works fine. I contacted my LMS provider, their response was, it's not on our end, it must be how you created the course. Any ideas, other then making it a step by step recording?

12 Replies
Peter Anderson

Hey Edward!

Could be that your LMS doesn't support the MP4 mime type

I'd also recommend testing your course in SCORM Cloud to help us determine if the issue is Articulate-related or if it's on your LMS's side. If it appears in SCORM Cloud as well, we'd be happy to take a closer look at what might be going on. If you can't replicate the issue in SCORM Cloud, it's probably an issue that you'd want to take to your LMS team. The articles here and here may also help clear up common LMS issues.

Thanks!

Edward Springer

Peter,

Loaded course in SCORM Cloud and it played flawlessly. Unfortunately, our LMS provider said it was not on their end and suggested it was in the course itself. Don’t know if this makes any difference, but, over the past two days, Storyline has crashed five times. Three times I received an error message (do not recall what it said, next time I’ll grab a screen shot and forward it to you), following that it shut down. The other two times was after clicking the Save button Storyline locked up and had to be shut down from Task Manager (Task Manager showed Storyline as Not Responding). The last crash occurred earlier today. I was working with a scene of a step by step screen recording, adding audio. After each audio recording I saved the file. About half way through it locked up and crashed. When I restarted Storyline, the entire scene was gone! On a couple of previous occasions I found that if Storyline was open for too long, it would start to act odd, not being able to reposition individual slides in a scene, or copy slides form one scene to another. After shutting down and restarting, problems went away.

Any help you can provide will be very much appreciated.

Peter Anderson

Sorry to hear about the issues you've been having, Edward. 

SCORM Cloud is the industry standard for testing SCORM content, so if it worked flawlessly on SCORM Cloud, the issue would most certainly be coming from your LMS provider. Did you have a chance to ask them about the MP4 mime type? 

As far as the erratic behavior, can you confirm that you're following these general rules to prevent weirdness?:

  • Work on your local drive (your C: drive). Working on a network drive or a USB drive can cause erratic behavior, including file corruption, loss of audio, and other unexpected behavior. 
  • You should also make sure the directory path to your project files and your published output is less than 260 characters (for example C:\Articulate).
  • Avoid using special characters, accents or symbols in your file names.

Thanks, and don't hesitate to let us know if you run into other issues going forward

Edward Springer

Peter,

Thanks for the suggetions on avoiding erratic behavior. It may be due to the way our company sets up computers and locks them down. Heard from a collegue that he is having issues as well. So far, can't get LMS vendor to respond to MP4 mime type inquiry. Oh, how I wish there was a Mac version of Storyline!

Peter Anderson

Hey Edward!

I hear ya, regarding a Mac version - probably our most requested "feature"

I hope your IT / LMS department is able to step in and help out soon. 

If you'd like further evidence to support that the issue is most likely confined to their end, you can quickly upload and share your course through Tempshare. Again, if it plays properly there, it would indicate a server setting needs to be changed where you're hosting. 

Good luck, Edward!

Maria Darst

Hi, I am having the same problem. The step by step recording plays fine --just the single slide recording having the same behavior you described. Could be a similar issue with mp4 mime file. We are running MaxIt's learnerWeb. 

I'll use a WebObject instead. Care to share your workaround?

Thanks for the information!

Maria

Maria Darst

Anyone tried this?

If MP4 videos do not display when your Articulate content is hosted on a server, it's likely that the server is not configured to play these files.

Some servers do not have an associated MIME type to support MP4 files.  To correct this issue, add an MP4 MIME type to your server.  Here's how:

  1. Right-click the site in IIS and select Properties.
  2. Select the HTTP Headers Tab.
  3. Select File Types.
  4. Under the MIME Map section, select New Type.
  5. Type ".mp4" as the associated extension and "video/mpeg" as the content type.
  6. Click OK.

Your MP4 movies should now play when viewed from the server.  If you use a hosting company to host your files, it's best to check with them about adding MP4 as a supported MIME type.

See also:

Ashley Terwilliger

Hi Maria,

This thread is a bit older so I'm not certain that Edward is still subscribed. The most common solution is to ensure the appropriate mime type is installed, and that was what Edward's LMS team finally shared. There are some other reasons documented here on why a video may not play within your published content. 

Maria Darst

Maria Darst said:

Anyone tried this?

If MP4 videos do not display when your Articulate content is hosted on a server, it's likely that the server is not configured to play these files.

Some servers do not have an associated MIME type to support MP4 files.  To correct this issue, add an MP4 MIME type to your server.  Here's how:

  1. Right-click the site in IIS and select Properties.
  2. Select the HTTP Headers Tab.
  3. Select File Types.
  4. Under the MIME Map section, select New Type.
  5. Type ".mp4" as the associated extension and "video/mpeg" as the content type.
  6. Click OK.

Your MP4 movies should now play when viewed from the server.  If you use a hosting company to host your files, it's best to check with them about adding MP4 as a supported MIME type.

See also:

I've updated our server with the above instructions and it's working like a charm!  Thank you! Thank you!!