Scroll panel bar missing within edit window, but visible on preview and publish

I have a long page with lots of hotspots on it inside of a scrolling panel as part of an interaction. This was working great yesterday (scroll bar visible in edit as well as preview) until it suddenly disappeared within the edit window (but is still visible on preview and publish) and I can't figure out why or how to fix it. The missing scroll bar has made it impossible to navigate within the scroll window and continue editing my interaction. I've seen other discussions referencing the opposite problem - the scroll bar is visible while editing but missing on publish - but none like this one. Can anyone help me?

5 Replies
Christie Pollick

Hi, Tamika -- Thanks so much for reaching out and sorry to hear of your troubles! May I ask if you can first confirm that you are working locally as described here? And if issues persist, you are welcome to share your file so we can take a closer look (for private review, click here), and these troubleshooting steps might also help you find improvement. 

Tamika Base

Hi Christie,

To answer your questions, I am working locally on my machine, and I've recently reinstalled Storyline 2, but I haven't done it again today. 

 

I wasn't able to fix it, but I WAS able to begin a new slide and build it again without encountering the issue, so I'm guessing it became corrupted. I'll upload a project file with the offending slide in case it helps to troubleshoot the scroll bar functionality in the future.

Christie Pollick

Hi, Tamika -- Thanks so much for your reply, and thanks for mentioning that a new slide was the key! With respects to potential corruption, I did want to pass along this great article: Follow These Tips to Reduce Your Risk of Corrupting or Losing Project Files. 

Also, your case #00838531 has been received! I'll check it out as soon as possible and with reply within your case via email with my findings. Your patience is appreciated! 

Kelli Williams

Do the trouble-shooting steps in the linked article work for Storyline 360?  I'm having the same issue.  Was setting up a scroll bar with 46, 3-letter location codes.  I set up a hover state for each location code.  Then I started setting up the triggers.  I got about 6 codes into it and decided to preview it just to make sure it was working before getting through all 46.  In preview mode the scroll bar wasn't there so I closed out of preview and went back to the slide and nor is it visible on the slide anymore. 

  • I checked my timeline, all codes are inside the scroll panel field.  
  • I tried adding a new slide like one of the other commenters said, but when I added the scroll panel it did not have the scroll bar from the get go. 
  • I tried exiting, rebooting and relaunching SL360 - still missing.

Was going to start trying some of the trouble-shooting items listed in this other thread, but it says it's for Storyline 2.  This thread is 5 years old, so just wondered if there was anything different I should try for SL360.  Thanks!

Ren Gomez

Hi Kelli,

Sorry to hear your scrolling panel is missing! There can be so many reasons why corruption happens, and while it's no silver bullet, the article linked above contains valuable tips on reducing risk for Storyline 360 as well!

If you find yourself always running into the same issue, connect with our support engineers, and they'll be able to give you a heads up on the file to see if it's genuinely corrupted, or if they can provide a workaround!